Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение ячееек только по рабочим дням - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячееек только по рабочим дням (Формулы/Formulas)
Автоматическое заполнение ячееек только по рабочим дням
dndndn Дата: Вторник, 26.12.2023, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, необходима помощь, есть график в котором есть месяц, год и даты, необходимо чтоб ячейки в строке ЧАСЫ заполнялись по рабочим, субботам, воскресеньям и праздничным дням согласно указанным часам в желтых ячейках, например цифрой 8 (количество часов) будни, в сб 4 ч, вс 2 ч, и праздничные 3 ч., чтоб не заполнять каждую ячейку вручную. Образец прилагаю.
К сообщению приложен файл: obrazec.xlsx (9.8 Kb)
 
Ответить
СообщениеДобрый день, необходима помощь, есть график в котором есть месяц, год и даты, необходимо чтоб ячейки в строке ЧАСЫ заполнялись по рабочим, субботам, воскресеньям и праздничным дням согласно указанным часам в желтых ячейках, например цифрой 8 (количество часов) будни, в сб 4 ч, вс 2 ч, и праздничные 3 ч., чтоб не заполнять каждую ячейку вручную. Образец прилагаю.

Автор - dndndn
Дата добавления - 26.12.2023 в 15:17
elovkov Дата: Вторник, 26.12.2023, 15:40 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
На листе 2 создать базу праздничных дней и тогда вот такой конструкцией можно
Код
=ЕСЛИ(ЕСЛИОШИБКА(ВПР(B2;Лист2!$A1:$A8;1;0);0)>0;$AJ$2;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;$AH$2;ЕСЛИ(ДЕНЬНЕД(B2;2)=7;$AI$2;$AG$2)))

Главное определиться - субботы и воскресенья если праздники - то сколько часов? Если 3 то включать их в базу, если 4 и 2 - то не включать
И там где дни - там формат ячейки "Д" и проставлять дату полностью, чтобы понимал дни недели

upd: посмотрел, элемент ">0" в формуле лишний, можно на 2 символа сократить)))
К сообщению приложен файл: obrazec_1.xlsx (12.2 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Вторник, 26.12.2023, 16:14
 
Ответить
СообщениеНа листе 2 создать базу праздничных дней и тогда вот такой конструкцией можно
Код
=ЕСЛИ(ЕСЛИОШИБКА(ВПР(B2;Лист2!$A1:$A8;1;0);0)>0;$AJ$2;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;$AH$2;ЕСЛИ(ДЕНЬНЕД(B2;2)=7;$AI$2;$AG$2)))

Главное определиться - субботы и воскресенья если праздники - то сколько часов? Если 3 то включать их в базу, если 4 и 2 - то не включать
И там где дни - там формат ячейки "Д" и проставлять дату полностью, чтобы понимал дни недели

upd: посмотрел, элемент ">0" в формуле лишний, можно на 2 символа сократить)))

Автор - elovkov
Дата добавления - 26.12.2023 в 15:40
elovkov Дата: Вторник, 26.12.2023, 16:32 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Можно еще с днями и условным форматированием побаловаться для большей автоматизации на любой месяц
К сообщению приложен файл: 8190501.xlsx (13.3 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеМожно еще с днями и условным форматированием побаловаться для большей автоматизации на любой месяц

Автор - elovkov
Дата добавления - 26.12.2023 в 16:32
DrMini Дата: Вторник, 26.12.2023, 19:20 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте dndndn,
Как вариант в лоб для января 2024 года на Лист1:
Код
=ЕСЛИ(НЕ(ЕНД(ГПР(B2;$B$2:$I$2;1;)));3;ЕСЛИ(ДЕНЬНЕД(B2;2)<6;8;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;4;2)))

без доп столбцов.
и, как недоделанный вариант с УФ и столбцом для праздников Лист2:
Код
=ЕСЛИ(НЕ(ЕНД(ВПР(B2;$AL$2:$AL$20;1;)));3;ЕСЛИ(ДЕНЬНЕД(B2;2)<6;8;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;4;2)))
К сообщению приложен файл: obraz.xlsx (15.8 Kb)
 
Ответить
СообщениеЗдравствуйте dndndn,
Как вариант в лоб для января 2024 года на Лист1:
Код
=ЕСЛИ(НЕ(ЕНД(ГПР(B2;$B$2:$I$2;1;)));3;ЕСЛИ(ДЕНЬНЕД(B2;2)<6;8;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;4;2)))

без доп столбцов.
и, как недоделанный вариант с УФ и столбцом для праздников Лист2:
Код
=ЕСЛИ(НЕ(ЕНД(ВПР(B2;$AL$2:$AL$20;1;)));3;ЕСЛИ(ДЕНЬНЕД(B2;2)<6;8;ЕСЛИ(ДЕНЬНЕД(B2;2)=6;4;2)))

Автор - DrMini
Дата добавления - 26.12.2023 в 19:20
dndndn Дата: Вторник, 26.12.2023, 19:24 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное, буду что нибудь лепить из предложенных вариантов!
 
Ответить
СообщениеСпасибо огромное, буду что нибудь лепить из предложенных вариантов!

Автор - dndndn
Дата добавления - 26.12.2023 в 19:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячееек только по рабочим дням (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!