Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отобразить список по условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Отобразить список по условиям
Crossjaw Дата: Четверг, 08.02.2024, 10:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Всем привет!

Есть таблица с базой данных, которая будет пополняться/изменяться ежемесячно. Сейчас в ней (я вырезал кусок) около 300 строк, но к концу года может быть и больше, как пойдёт.
Мне надо, чтобы на отдельном листе формировался список из значений 3-х столбцов, на основании значений который я пропишу в столбце "Статус", "РЭС "и "Тип".
И самое главное, если бы в одном из них написано "Любой", или пустое место, то это означает, что будут выбираться все значения.
Очень сложно объяснить, как мне кажется, но я пример прикреплю.
Во втором листе "Что должно получиться" я прописал "фильтры" по которым уже сформированы списки, но я, естественно, сделал это вручную.

Причём надо именно два списка (пример в приложении, на листе "Что должно получиться")

Как можно решить эту задачу? Хочется это автоматизировать. Если бы получилось, то это бы в МИЛЛИАРДЫ раз упростило мою работу

Очень прошу Вашей помощи!
К сообщению приложен файл: data_08_02_2024.xlsx (14.9 Kb)


Сообщение отредактировал Crossjaw - Четверг, 08.02.2024, 10:49
 
Ответить
СообщениеВсем привет!

Есть таблица с базой данных, которая будет пополняться/изменяться ежемесячно. Сейчас в ней (я вырезал кусок) около 300 строк, но к концу года может быть и больше, как пойдёт.
Мне надо, чтобы на отдельном листе формировался список из значений 3-х столбцов, на основании значений который я пропишу в столбце "Статус", "РЭС "и "Тип".
И самое главное, если бы в одном из них написано "Любой", или пустое место, то это означает, что будут выбираться все значения.
Очень сложно объяснить, как мне кажется, но я пример прикреплю.
Во втором листе "Что должно получиться" я прописал "фильтры" по которым уже сформированы списки, но я, естественно, сделал это вручную.

Причём надо именно два списка (пример в приложении, на листе "Что должно получиться")

Как можно решить эту задачу? Хочется это автоматизировать. Если бы получилось, то это бы в МИЛЛИАРДЫ раз упростило мою работу

Очень прошу Вашей помощи!

Автор - Crossjaw
Дата добавления - 08.02.2024 в 10:48
Nic70y Дата: Четверг, 08.02.2024, 11:10 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
вариант с доп.столбцами
К сообщению приложен файл: 400.xlsx (30.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант с доп.столбцами

Автор - Nic70y
Дата добавления - 08.02.2024 в 11:10
alexa1965 Дата: Четверг, 08.02.2024, 11:40 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 344
Репутация: 56 ±
Замечаний: 0% ±

2003> 2019 >2016
Доброго дня! Массивными формулами без всяких допстолбцов
Код
=ИНДЕКС(База!A$1:A$1000;НАИМЕНЬШИЙ(ЕСЛИ(База!E$3:E$1000='Что должно получиться'!G$1;СТРОКА(База!A$3:A$1000);1000);СТРОКА(A1)))
для ячейки А5 что должно получиться и соответственно для ячейки I5
Код
=ИНДЕКС(База!A$1:A$1000;НАИМЕНЬШИЙ(ЕСЛИ((База!E$3:E$1000='Что должно получиться'!O$1)*(База!D$3:D$1000='Что должно получиться'!O$2)*(База!B$3:B$1000='Что должно получиться'!O$3);СТРОКА(База!A$3:A$1000);1000);СТРОКА(A1)))
К сообщению приложен файл: 1555651.xlsx (16.9 Kb)


Главное не быть балабастиком
 
Ответить
СообщениеДоброго дня! Массивными формулами без всяких допстолбцов
Код
=ИНДЕКС(База!A$1:A$1000;НАИМЕНЬШИЙ(ЕСЛИ(База!E$3:E$1000='Что должно получиться'!G$1;СТРОКА(База!A$3:A$1000);1000);СТРОКА(A1)))
для ячейки А5 что должно получиться и соответственно для ячейки I5
Код
=ИНДЕКС(База!A$1:A$1000;НАИМЕНЬШИЙ(ЕСЛИ((База!E$3:E$1000='Что должно получиться'!O$1)*(База!D$3:D$1000='Что должно получиться'!O$2)*(База!B$3:B$1000='Что должно получиться'!O$3);СТРОКА(База!A$3:A$1000);1000);СТРОКА(A1)))

Автор - alexa1965
Дата добавления - 08.02.2024 в 11:40
Crossjaw Дата: Четверг, 08.02.2024, 11:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

вариант с доп.столбцами


Просто офигеть!!! Нет слов!!! Чудеса! clap У меня рот до сих пор открыт shock

Всё, что вы там прописали для меня абсолютно непонятно, хотя у себя в организации по Экселю я считаюсь главным Гуру))) Вот это я понимаю на каком дне по знаниям я нахожусь) Жесть.

Появился ещё вопрос. А я могу где-то обучиться такой же магией? Есть может быть гайд или что-то вроде того по которому вы обучались?) Надеюсь, это был не Хогвартс

Я сейчас попробую перенести это в свой основной файл. Надеюсь получится)
 
Ответить
Сообщение
вариант с доп.столбцами


Просто офигеть!!! Нет слов!!! Чудеса! clap У меня рот до сих пор открыт shock

Всё, что вы там прописали для меня абсолютно непонятно, хотя у себя в организации по Экселю я считаюсь главным Гуру))) Вот это я понимаю на каком дне по знаниям я нахожусь) Жесть.

Появился ещё вопрос. А я могу где-то обучиться такой же магией? Есть может быть гайд или что-то вроде того по которому вы обучались?) Надеюсь, это был не Хогвартс

Я сейчас попробую перенести это в свой основной файл. Надеюсь получится)

Автор - Crossjaw
Дата добавления - 08.02.2024 в 11:41
elovkov Дата: Четверг, 08.02.2024, 11:49 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
у себя в организации по Экселю я считаюсь главным Гуру)

Года полтора назад я тоже так про себя думал, пока не попал на этот сайт)))
С тех пор тут сижу постоянно, теперь знаю немного больше чем раньше)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
у себя в организации по Экселю я считаюсь главным Гуру)

Года полтора назад я тоже так про себя думал, пока не попал на этот сайт)))
С тех пор тут сижу постоянно, теперь знаю немного больше чем раньше)))

Автор - elovkov
Дата добавления - 08.02.2024 в 11:49
Nic70y Дата: Четверг, 08.02.2024, 11:50 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
по которому вы обучались?)
когда у меня не было интернета - это была справка эксель,
а потом форумы, на которых, помогая другим и подглядывая за ответами помогающих - научился сам


ЮMoney 41001841029809
 
Ответить
Сообщение
по которому вы обучались?)
когда у меня не было интернета - это была справка эксель,
а потом форумы, на которых, помогая другим и подглядывая за ответами помогающих - научился сам

Автор - Nic70y
Дата добавления - 08.02.2024 в 11:50
Crossjaw Дата: Четверг, 08.02.2024, 11:51 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

alexa1965, тоже очень круто выглядит, минималистично, но не работает, если в столбцах по которым делается выборка прописать "Любой"
К сообщению приложен файл: 555.xlsx (34.0 Kb)


Сообщение отредактировал Serge_007 - Четверг, 08.02.2024, 12:02
 
Ответить
Сообщениеalexa1965, тоже очень круто выглядит, минималистично, но не работает, если в столбцах по которым делается выборка прописать "Любой"

Автор - Crossjaw
Дата добавления - 08.02.2024 в 11:51
Nic70y Дата: Четверг, 08.02.2024, 12:17 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
Crossjaw, если хочется массивную - вариант:
Код
=ЕСЛИОШИБКА(ИНДЕКС(База!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(ПОДСТАВИТЬ($G$1&"\"&$G$2&"\"&$G$3;"Любой";"*");База!$E$3:$E$999&"\"&База!$D$3:$D$999&"\"&База!$B$3:$B$999));СТРОКА(База!$B$3:$B$999));СТРОКА(A1)));"")
К сообщению приложен файл: 627.xlsx (39.9 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеCrossjaw, если хочется массивную - вариант:
Код
=ЕСЛИОШИБКА(ИНДЕКС(База!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(ПОДСТАВИТЬ($G$1&"\"&$G$2&"\"&$G$3;"Любой";"*");База!$E$3:$E$999&"\"&База!$D$3:$D$999&"\"&База!$B$3:$B$999));СТРОКА(База!$B$3:$B$999));СТРОКА(A1)));"")

Автор - Nic70y
Дата добавления - 08.02.2024 в 12:17
Crossjaw Дата: Четверг, 08.02.2024, 12:35 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

если хочется массивную - вариант:


Огромное спасибо! :)
Получилось перенести в свой основной файл. Теперь буду пытаться разобрать что Вы тут понаписали, чтобы в будущем похожие трюки исполнять)))
 
Ответить
Сообщение
если хочется массивную - вариант:


Огромное спасибо! :)
Получилось перенести в свой основной файл. Теперь буду пытаться разобрать что Вы тут понаписали, чтобы в будущем похожие трюки исполнять)))

Автор - Crossjaw
Дата добавления - 08.02.2024 в 12:35
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!