Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение, поиск и вывод данных на листах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение, поиск и вывод данных на листах (Формулы/Formulas)
Сравнение, поиск и вывод данных на листах
kirill_23 Дата: Понедельник, 01.02.2016, 06:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Прошу знающих подсказать.
1 лист с данными(числовыми"номера").
Лист 2 с такими же данными числовыми(по строкам не одинаковые)
Нужно сопоставить данные столбца А лист1 со столбцом В лист 2, при нахождении одинаковых, вывести данные с листа 2 столбец С равные строке в которой номер.
Вложил пример. А то вручную поиском очень долго искать
К сообщению приложен файл: Primer.xlsx(16Kb)
 
Ответить
СообщениеДобрый день. Прошу знающих подсказать.
1 лист с данными(числовыми"номера").
Лист 2 с такими же данными числовыми(по строкам не одинаковые)
Нужно сопоставить данные столбца А лист1 со столбцом В лист 2, при нахождении одинаковых, вывести данные с листа 2 столбец С равные строке в которой номер.
Вложил пример. А то вручную поиском очень долго искать

Автор - kirill_23
Дата добавления - 01.02.2016 в 06:18
mathiax90 Дата: Понедельник, 01.02.2016, 06:43 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
ВПР
К сообщению приложен файл: 6930562.xlsx(23Kb)


webmoney: R242692021885
ЯД:410013877261817
 
Ответить
СообщениеВПР

Автор - mathiax90
Дата добавления - 01.02.2016 в 06:43
mathiax90 Дата: Понедельник, 01.02.2016, 06:45 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007


webmoney: R242692021885
ЯД:410013877261817
 
Ответить
СообщениеИли так:
http://www.excelworld.ru/publ....7-1-0-1

Автор - mathiax90
Дата добавления - 01.02.2016 в 06:45
kirill_23 Дата: Понедельник, 01.02.2016, 07:03 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А без =СЖПРОБЕЛЫ(A3)&"."&СЖПРОБЕЛЫ(B3) возможно по одному номеру?
 
Ответить
СообщениеА без =СЖПРОБЕЛЫ(A3)&"."&СЖПРОБЕЛЫ(B3) возможно по одному номеру?

Автор - kirill_23
Дата добавления - 01.02.2016 в 07:03
китин Дата: Понедельник, 01.02.2016, 07:20 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так подойдет?формула массива
Код
=ИНДЕКС(Лист2!$C$2:$C$120;ПОИСКПОЗ(A2&B2;Лист2!$B$2:$B$120&Лист2!$A$2:$A$120;0))

[offtop]mathiax90 просьба:выкладывайте пожалуйста ваши формулы в тело поста, в тэгах. Не всегда охота файлы качать :D
К сообщению приложен файл: kirill_23.xlsx(19Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 01.02.2016, 07:25
 
Ответить
Сообщениетак подойдет?формула массива
Код
=ИНДЕКС(Лист2!$C$2:$C$120;ПОИСКПОЗ(A2&B2;Лист2!$B$2:$B$120&Лист2!$A$2:$A$120;0))

[offtop]mathiax90 просьба:выкладывайте пожалуйста ваши формулы в тело поста, в тэгах. Не всегда охота файлы качать :D

Автор - китин
Дата добавления - 01.02.2016 в 07:20
kirill_23 Дата: Понедельник, 01.02.2016, 07:45 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Благодарю.А если мы имеим разные названия и одинаковые номера?Как перечислить через запятую?
Поз 23. закрасил желтым
К сообщению приложен файл: 2946752.xlsx(18Kb)


Сообщение отредактировал kirill_23 - Понедельник, 01.02.2016, 08:27
 
Ответить
СообщениеБлагодарю.А если мы имеим разные названия и одинаковые номера?Как перечислить через запятую?
Поз 23. закрасил желтым

Автор - kirill_23
Дата добавления - 01.02.2016 в 07:45
mathiax90 Дата: Понедельник, 01.02.2016, 08:16 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
А без =СЖПРОБЕЛЫ(A3)&"."&СЖПРОБЕЛЫ(B3) возможно по одному номеру?
Что значит по одному номер?
Вы сводите таблицу по одному столбцу или по двум?
Если по одному то, просто ВПР.
Если по двум, то либо вариант Китина либо мой.


webmoney: R242692021885
ЯД:410013877261817
 
Ответить
СообщениеА без =СЖПРОБЕЛЫ(A3)&"."&СЖПРОБЕЛЫ(B3) возможно по одному номеру?
Что значит по одному номер?
Вы сводите таблицу по одному столбцу или по двум?
Если по одному то, просто ВПР.
Если по двум, то либо вариант Китина либо мой.

Автор - mathiax90
Дата добавления - 01.02.2016 в 08:16
kirill_23 Дата: Понедельник, 01.02.2016, 08:46 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А если выводить через запятую? Где номер один а данные разные...Пример выше
 
Ответить
СообщениеА если выводить через запятую? Где номер один а данные разные...Пример выше

Автор - kirill_23
Дата добавления - 01.02.2016 в 08:46
_Boroda_ Дата: Понедельник, 01.02.2016, 09:43 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11527
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Через запятую обязательно? Так намного сложнее или с допстолбцом.
Если в соседние ячейки, то вот так можно
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС(Лист2!$C$1:$C$122;НАИМЕНЬШИЙ(ЕСЛИ($A2=Лист2!$B$2:$B$121;СТРОКА(Лист2!$B$2:$B$121);122);СТОЛБЕЦ(A2)))&""

Еще вариант обычной формулой в разные ячейки
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(Лист2!$B$2:$B$121=$A2)/ЕНД(ПОИСКПОЗ(Лист2!$C$2:$C$121;$B2:B2;));Лист2!$C$2:$C$121);"")

Ща чуть попозже приложу с допстолбцом, если нужно

Довложил файл _2 с выводом в одну ячейку через запятую. С допстолбцом в Лист2
К сообщению приложен файл: 2946752_1.xlsx(22Kb) · 2946752_2.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧерез запятую обязательно? Так намного сложнее или с допстолбцом.
Если в соседние ячейки, то вот так можно
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС(Лист2!$C$1:$C$122;НАИМЕНЬШИЙ(ЕСЛИ($A2=Лист2!$B$2:$B$121;СТРОКА(Лист2!$B$2:$B$121);122);СТОЛБЕЦ(A2)))&""

Еще вариант обычной формулой в разные ячейки
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(Лист2!$B$2:$B$121=$A2)/ЕНД(ПОИСКПОЗ(Лист2!$C$2:$C$121;$B2:B2;));Лист2!$C$2:$C$121);"")

Ща чуть попозже приложу с допстолбцом, если нужно

Довложил файл _2 с выводом в одну ячейку через запятую. С допстолбцом в Лист2

Автор - _Boroda_
Дата добавления - 01.02.2016 в 09:43
kirill_23 Дата: Понедельник, 01.02.2016, 09:54 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Через запятую обязательно? Так намного сложнее или с допстолбцом.

Ну обычно просто таблица большая, и получается столбец в середине
 
Ответить
Сообщение
Через запятую обязательно? Так намного сложнее или с допстолбцом.

Ну обычно просто таблица большая, и получается столбец в середине

Автор - kirill_23
Дата добавления - 01.02.2016 в 09:54
_Boroda_ Дата: Понедельник, 01.02.2016, 09:58 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11527
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Уже сделал и довложил файл в свое сообщение выше


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУже сделал и довложил файл в свое сообщение выше

Автор - _Boroda_
Дата добавления - 01.02.2016 в 09:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение, поиск и вывод данных на листах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!