Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вынесение масксимального значения из массива в столбец - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вынесение масксимального значения из массива в столбец (Формулы/Formulas)
Вынесение масксимального значения из массива в столбец
argetlam Дата: Вторник, 17.05.2016, 13:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день, комрады!
Есть двумерный массив с рандомными числовыми значениями, из него нужно выдернуть максимальное и внести в пустую табличку. Но! Это значение должно быть только в том же столбце, что и максимальное, но в рандомной строке, а все остальные ячейки должны быть пустыми (либо нули).
Есть ли возможность сделать это стандартными средствами?
Файл с примером приложил.
К сообщению приложен файл: 8636363.xls(30Kb)
 
Ответить
СообщениеДобрый день, комрады!
Есть двумерный массив с рандомными числовыми значениями, из него нужно выдернуть максимальное и внести в пустую табличку. Но! Это значение должно быть только в том же столбце, что и максимальное, но в рандомной строке, а все остальные ячейки должны быть пустыми (либо нули).
Есть ли возможность сделать это стандартными средствами?
Файл с примером приложил.

Автор - argetlam
Дата добавления - 17.05.2016 в 13:18
VIDEO56 Дата: Вторник, 17.05.2016, 13:24 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Так нужно?
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;C15:C27)

Код
=МАКС(C15:C27)
К сообщению приложен файл: 5026251.xls(25Kb)


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Вторник, 17.05.2016, 13:37
 
Ответить
СообщениеТак нужно?
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;C15:C27)

Код
=МАКС(C15:C27)

Автор - VIDEO56
Дата добавления - 17.05.2016 в 13:24
pabchek Дата: Вторник, 17.05.2016, 13:24 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
И мой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$15:D$27;ПОИСКПОЗ(МАКС($C$15:$E$27);D$15:D$27;0));"")
К сообщению приложен файл: 9861295.xls(28Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 13:25
 
Ответить
СообщениеИ мой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$15:D$27;ПОИСКПОЗ(МАКС($C$15:$E$27);D$15:D$27;0));"")

Автор - pabchek
Дата добавления - 17.05.2016 в 13:24
_Boroda_ Дата: Вторник, 17.05.2016, 13:47 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
значение должно быть ... в рандомной строке

Может так (розовое)?
Код
=ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ(СЛЧИС()<СТРОКА(C1)/5;МАКС(C15:C27);""))

Или лучше вывести случайное в отдельную ячейку (зеленое), так равномерное распределение будет равномернее :D
К сообщению приложен файл: 8636363_1.xls(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
значение должно быть ... в рандомной строке

Может так (розовое)?
Код
=ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ(СЛЧИС()<СТРОКА(C1)/5;МАКС(C15:C27);""))

Или лучше вывести случайное в отдельную ячейку (зеленое), так равномерное распределение будет равномернее :D

Автор - _Boroda_
Дата добавления - 17.05.2016 в 13:47
argetlam Дата: Вторник, 17.05.2016, 14:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
VIDEO56, pabchek, Варианты хорошие, но если формулу протянуть на все строки - значение попадет во все строки.
_Boroda_, тоже хороший вариант, но я видимо непонятно написал - значение должно быть одно на всю таблицу, у Вас выходит по максимальному значению для каждого столбца.
Но если скомбинировать ваши решения, то получится то что требовалось:)
Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ(СЛЧИС()<СТРОКА(C1)/5;ИНДЕКС(C$15:C$27;ПОИСКПОЗ(МАКС($C$15:$E$27);C$15:C$27;0));""));"")
К сообщению приложен файл: 0724815.xls(30Kb)
 
Ответить
СообщениеVIDEO56, pabchek, Варианты хорошие, но если формулу протянуть на все строки - значение попадет во все строки.
_Boroda_, тоже хороший вариант, но я видимо непонятно написал - значение должно быть одно на всю таблицу, у Вас выходит по максимальному значению для каждого столбца.
Но если скомбинировать ваши решения, то получится то что требовалось:)
Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ(СЛЧИС()<СТРОКА(C1)/5;ИНДЕКС(C$15:C$27;ПОИСКПОЗ(МАКС($C$15:$E$27);C$15:C$27;0));""));"")

Автор - argetlam
Дата добавления - 17.05.2016 в 14:46
_Boroda_ Дата: Вторник, 17.05.2016, 15:01 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так можно
Код
=ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ((СЛЧИС()<СТРОКА(C1)/5)*СУММЕСЛИ(C$15:C$27;МАКС($C$15:$E$27));МАКС($C$15:$E$27);""))
К сообщению приложен файл: 8636363_2.xls(33Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так можно
Код
=ЕСЛИ(СУММ(C$4:C4);"";ЕСЛИ((СЛЧИС()<СТРОКА(C1)/5)*СУММЕСЛИ(C$15:C$27;МАКС($C$15:$E$27));МАКС($C$15:$E$27);""))

Автор - _Boroda_
Дата добавления - 17.05.2016 в 15:01
argetlam Дата: Вторник, 17.05.2016, 15:05 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
_Boroda_, не вижу смысла выносить Слчисл(), и так вроде достаточно рандомно скачет)
 
Ответить
Сообщение_Boroda_, не вижу смысла выносить Слчисл(), и так вроде достаточно рандомно скачет)

Автор - argetlam
Дата добавления - 17.05.2016 в 15:05
pabchek Дата: Вторник, 17.05.2016, 15:16 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
или еще вариант (правда с вынесением СЛУЧМЕЖДУ)
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=$L$1;ВПР(МАКС($K$15:$M$27);K$15:K$27;1;0);"");"")

по идее совсем рандомно должно быть))
К сообщению приложен файл: 4243372.xls(34Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 15:22
 
Ответить
Сообщениеили еще вариант (правда с вынесением СЛУЧМЕЖДУ)
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=$L$1;ВПР(МАКС($K$15:$M$27);K$15:K$27;1;0);"");"")

по идее совсем рандомно должно быть))

Автор - pabchek
Дата добавления - 17.05.2016 в 15:16
_Boroda_ Дата: Вторник, 17.05.2016, 15:18 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не вижу смысла выносить Слчисл()

Ну, не совсем. Где-то такой расклад получается
20%
32%
29%
15%
4%


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не вижу смысла выносить Слчисл()

Ну, не совсем. Где-то такой расклад получается
20%
32%
29%
15%
4%

Автор - _Boroda_
Дата добавления - 17.05.2016 в 15:18
pabchek Дата: Вторник, 17.05.2016, 15:37 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Или без выноса. Рэндом полный, проверка на втором листе
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=ОКРУГЛ(ОТБР(СЛЧИС()*10)/2+4,5;0);ВПР(МАКС($K$15:$M$27);O$15:O$27;1;0);"");"")

Упс. Ошибочка. Щас))
К сообщению приложен файл: 4647950.xls(90Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 15:38
 
Ответить
СообщениеИли без выноса. Рэндом полный, проверка на втором листе
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=ОКРУГЛ(ОТБР(СЛЧИС()*10)/2+4,5;0);ВПР(МАКС($K$15:$M$27);O$15:O$27;1;0);"");"")

Упс. Ошибочка. Щас))

Автор - pabchek
Дата добавления - 17.05.2016 в 15:37
argetlam Дата: Вторник, 17.05.2016, 15:48 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
pabchek, привязка к строке - это грустно, танцевать надо будет с каждым изменением диапазона :D
_Boroda_, странно, теперь заметил, а почему так? 0_о


Сообщение отредактировал argetlam - Вторник, 17.05.2016, 15:49
 
Ответить
Сообщениеpabchek, привязка к строке - это грустно, танцевать надо будет с каждым изменением диапазона :D
_Boroda_, странно, теперь заметил, а почему так? 0_о

Автор - argetlam
Дата добавления - 17.05.2016 в 15:48
pabchek Дата: Вторник, 17.05.2016, 16:00 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
вот. такого монстра
Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММ(O$4:O4);"";ЕСЛИ(СТРОКА()=ОКРУГЛ(ОТБР(СЛЧИС()*10)*(9-СТРОКА())/10+СТРОКА()-0,5;0);ВПР(МАКС($K$15:$M$27);O$15:O$27;1;0);""));"")
К сообщению приложен файл: 4036976.xls(83Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 16:39
 
Ответить
Сообщениевот. такого монстра
Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММ(O$4:O4);"";ЕСЛИ(СТРОКА()=ОКРУГЛ(ОТБР(СЛЧИС()*10)*(9-СТРОКА())/10+СТРОКА()-0,5;0);ВПР(МАКС($K$15:$M$27);O$15:O$27;1;0);""));"")

Автор - pabchek
Дата добавления - 17.05.2016 в 16:00
_Boroda_ Дата: Вторник, 17.05.2016, 16:10 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а почему так?

По математике.
Первое значение - 1/5=20%
второе - из оставшихся 80% берем 2/5 = 32%
третье - из оставшихся 48% берем 3/5 = 29%
...

Вы что, думаете, я от нечего делать еще одну табличку сделал и написал
так равномерное распределение будет равномернее
?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
а почему так?

По математике.
Первое значение - 1/5=20%
второе - из оставшихся 80% берем 2/5 = 32%
третье - из оставшихся 48% берем 3/5 = 29%
...

Вы что, думаете, я от нечего делать еще одну табличку сделал и написал
так равномерное распределение будет равномернее
?

Автор - _Boroda_
Дата добавления - 17.05.2016 в 16:10
argetlam Дата: Вторник, 17.05.2016, 17:22 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
_Boroda_, нет, я просто не понял как это работает ^_^
 
Ответить
Сообщение_Boroda_, нет, я просто не понял как это работает ^_^

Автор - argetlam
Дата добавления - 17.05.2016 в 17:22
Светлый Дата: Среда, 18.05.2016, 10:16 | Сообщение № 15
Группа: Проверенные
Ранг: Обитатель
Сообщений: 294
Репутация: 73 ±
Замечаний: 0% ±

Excel 2007
Можно арифметически решить, но с выносом случайного в B4:
Код
=СЛУЧМЕЖДУ(СТРОКА(C5);СТРОКА(C9))

и в массиве:
Код
($B$4=СТРОКА())*(МАКС($C$15:$E$27)=МАКС(C$15:C$27))*МАКС($C$15:$E$27)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно арифметически решить, но с выносом случайного в B4:
Код
=СЛУЧМЕЖДУ(СТРОКА(C5);СТРОКА(C9))

и в массиве:
Код
($B$4=СТРОКА())*(МАКС($C$15:$E$27)=МАКС(C$15:C$27))*МАКС($C$15:$E$27)

Автор - Светлый
Дата добавления - 18.05.2016 в 10:16
argetlam Дата: Среда, 18.05.2016, 11:13 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Усложним задачу, представим, что диапазон в котором находятся числа динамичен, как и диапазон в котором будут вышеописанные формулы, как поступить тогда?:) только расчехлять макроинструментарий?)
 
Ответить
СообщениеУсложним задачу, представим, что диапазон в котором находятся числа динамичен, как и диапазон в котором будут вышеописанные формулы, как поступить тогда?:) только расчехлять макроинструментарий?)

Автор - argetlam
Дата добавления - 18.05.2016 в 11:13
pabchek Дата: Среда, 18.05.2016, 11:41 | Сообщение № 17
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Вариант по "усложнению"
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=$C$1;ВПР(МАКС($B$15:ИНДЕКС($D$15:$D$999;СЧЁТЗ($D$15:$D$999)));B$15:B$999;1;0);"");"")

Можно и количество столбцов сделать динамичным. Но формулы будут расти как на дрожжах. Оно надо?
К сообщению приложен файл: 0827321.xlsb(27Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 18.05.2016, 11:42
 
Ответить
СообщениеВариант по "усложнению"
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()=$C$1;ВПР(МАКС($B$15:ИНДЕКС($D$15:$D$999;СЧЁТЗ($D$15:$D$999)));B$15:B$999;1;0);"");"")

Можно и количество столбцов сделать динамичным. Но формулы будут расти как на дрожжах. Оно надо?

Автор - pabchek
Дата добавления - 18.05.2016 в 11:41
argetlam Дата: Среда, 18.05.2016, 12:28 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Можно и количество столбцов сделать динамичным. Но формулы будут расти как на дрожжах. Оно надо?

К сожалению - надо :(
Всем большое спасибо за помощь и предложенные варианты, но поскольку вопрос остался не решенным - он продолжил своё развитие в теме с VBA.
[moder]Не вопрос остался нерешенным, а Вы его изменили, четко изменения не описав. А в угадайку играть желающих немного обычно.


Сообщение отредактировал argetlam - Среда, 18.05.2016, 13:18
 
Ответить
Сообщение
Можно и количество столбцов сделать динамичным. Но формулы будут расти как на дрожжах. Оно надо?

К сожалению - надо :(
Всем большое спасибо за помощь и предложенные варианты, но поскольку вопрос остался не решенным - он продолжил своё развитие в теме с VBA.
[moder]Не вопрос остался нерешенным, а Вы его изменили, четко изменения не описав. А в угадайку играть желающих немного обычно.

Автор - argetlam
Дата добавления - 18.05.2016 в 12:28
argetlam Дата: Среда, 18.05.2016, 13:18 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Модератор:
Не вопрос остался нерешенным, а Вы его изменили, четко изменения не описав. А в угадайку играть желающих немного обычно.

Я извиняюсь за это, необходимость в изменениях появилась совсем недавно и формулой тут уже не обойтись, потому пришлось создать новую тему в другом разделе в соответствии с правилами.
 
Ответить
Сообщение
Модератор:
Не вопрос остался нерешенным, а Вы его изменили, четко изменения не описав. А в угадайку играть желающих немного обычно.

Я извиняюсь за это, необходимость в изменениях появилась совсем недавно и формулой тут уже не обойтись, потому пришлось создать новую тему в другом разделе в соответствии с правилами.

Автор - argetlam
Дата добавления - 18.05.2016 в 13:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вынесение масксимального значения из массива в столбец (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!