Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Из плоского списка разнести согласно месяцам и годам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из плоского списка разнести согласно месяцам и годам (Формулы/Formulas)
Из плоского списка разнести согласно месяцам и годам
vermut Дата: Вторник, 14.06.2016, 10:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Ребята добрый день :D Есть реестрежедневных операций дата/ наименвание/ кол-во; Из него необходимо разнести данные в разрезе месяцев и годов. Как с помощью суммеслимн сделать это? Файлик приложила
К сообщению приложен файл: ____.xlsx(16Kb)
 
Ответить
СообщениеРебята добрый день :D Есть реестрежедневных операций дата/ наименвание/ кол-во; Из него необходимо разнести данные в разрезе месяцев и годов. Как с помощью суммеслимн сделать это? Файлик приложила

Автор - vermut
Дата добавления - 14.06.2016 в 10:25
SkyPro Дата: Вторник, 14.06.2016, 10:33 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1206
Репутация: 253 ±
Замечаний: 0% ±

2010
Код
=СУММЕСЛИМН($C$3:$C$12;$D$3:$D$12;C$17;$E$3:$E$12;C$16;$B$3:$B$12;$A19)

для С19.
только год в шапке разбейте по ячейкам, что бы можно было растянуть формулу.
К сообщению приложен файл: 5409470.xlsx(11Kb)


skypro1111@gmail.com
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($C$3:$C$12;$D$3:$D$12;C$17;$E$3:$E$12;C$16;$B$3:$B$12;$A19)

для С19.
только год в шапке разбейте по ячейкам, что бы можно было растянуть формулу.

Автор - SkyPro
Дата добавления - 14.06.2016 в 10:33
китин Дата: Вторник, 14.06.2016, 10:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а без СУММЕСЛИМН?
Код
=СУММПРОИЗВ($C$3:$C$12*($B$3:$B$12=$A19)*($D$3:$D$12=B$17)*(ПРОСМОТР(;-КОДСИМВ($B$16:B$16);$B$16:B$16)=$E$3:$E$12))
К сообщению приложен файл: 123.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа без СУММЕСЛИМН?
Код
=СУММПРОИЗВ($C$3:$C$12*($B$3:$B$12=$A19)*($D$3:$D$12=B$17)*(ПРОСМОТР(;-КОДСИМВ($B$16:B$16);$B$16:B$16)=$E$3:$E$12))

Автор - китин
Дата добавления - 14.06.2016 в 10:38
Pelena Дата: Вторник, 14.06.2016, 10:39 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9848
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант без использования столбцов D и E, но в нижней таблице не просто номера месяцев, а даты
Код
=СУММПРОИЗВ($C$3:$C$12*(ТЕКСТ($A$3:$A$12;"ММГГ")=ТЕКСТ(B$17;"ММГГ"))*($B$3:$B$12=$A19))
К сообщению приложен файл: -3-.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант без использования столбцов D и E, но в нижней таблице не просто номера месяцев, а даты
Код
=СУММПРОИЗВ($C$3:$C$12*(ТЕКСТ($A$3:$A$12;"ММГГ")=ТЕКСТ(B$17;"ММГГ"))*($B$3:$B$12=$A19))

Автор - Pelena
Дата добавления - 14.06.2016 в 10:39
SkyPro Дата: Вторник, 14.06.2016, 10:40 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1206
Репутация: 253 ±
Замечаний: 0% ±

2010
китин, привет :)
как два пальца об асфальт:
Код
=СУММ((E3:E12=C$16)*($D$3:$D$12=C$17)*($B$3:$B$12=$A19)*$C$3:$C$12)
Массивная.

ну и без использования доп.столбцов:
Код
=СУММПРОИЗВ((МЕСЯЦ($A$3:$A$12)=C$17)*(ГОД($A$3:$A$12)=C$16)*($B$3:$B$12=$A19)*$C$3:$C$12)


skypro1111@gmail.com

Сообщение отредактировал SkyPro - Вторник, 14.06.2016, 10:43
 
Ответить
Сообщениекитин, привет :)
как два пальца об асфальт:
Код
=СУММ((E3:E12=C$16)*($D$3:$D$12=C$17)*($B$3:$B$12=$A19)*$C$3:$C$12)
Массивная.

ну и без использования доп.столбцов:
Код
=СУММПРОИЗВ((МЕСЯЦ($A$3:$A$12)=C$17)*(ГОД($A$3:$A$12)=C$16)*($B$3:$B$12=$A19)*$C$3:$C$12)

Автор - SkyPro
Дата добавления - 14.06.2016 в 10:40
китин Дата: Вторник, 14.06.2016, 10:44 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Привет Сергей.Рад тебя видеть снова !!!!.Но у тебя опять надо
год в шапке разбейте по ячейкам, что бы можно было растянуть формулу.

а у меня не надо!!!! :p


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеПривет Сергей.Рад тебя видеть снова !!!!.Но у тебя опять надо
год в шапке разбейте по ячейкам, что бы можно было растянуть формулу.

а у меня не надо!!!! :p

Автор - китин
Дата добавления - 14.06.2016 в 10:44
SkyPro Дата: Вторник, 14.06.2016, 10:45 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1206
Репутация: 253 ±
Замечаний: 0% ±

2010
Все равно у меня райт вей.
Обьединение ячеек = зло.
:)


skypro1111@gmail.com
 
Ответить
СообщениеВсе равно у меня райт вей.
Обьединение ячеек = зло.
:)

Автор - SkyPro
Дата добавления - 14.06.2016 в 10:45
_Boroda_ Дата: Вторник, 14.06.2016, 11:36 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Игорь новую игрушку нашел:
ПРОСМОТР(;-КОДСИМВ($B$16:B$16);$B$16:B$16)
:D :D :D

Еще вариант ничего в файлах не меняя
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$12;"МГГГ")=B$17&МАКС($B$16:B$16))*$C$3:$C$12*($B$3:$B$12=$A19))
К сообщению приложен файл: -1-1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИгорь новую игрушку нашел:
ПРОСМОТР(;-КОДСИМВ($B$16:B$16);$B$16:B$16)
:D :D :D

Еще вариант ничего в файлах не меняя
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$12;"МГГГ")=B$17&МАКС($B$16:B$16))*$C$3:$C$12*($B$3:$B$12=$A19))

Автор - _Boroda_
Дата добавления - 14.06.2016 в 11:36
vermut Дата: Вторник, 14.06.2016, 11:37 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Всем огромное спасибо ребята!!! :D
 
Ответить
СообщениеВсем огромное спасибо ребята!!! :D

Автор - vermut
Дата добавления - 14.06.2016 в 11:37
китин Дата: Вторник, 14.06.2016, 11:46 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
новую игрушку нашел

не , сам подбросил и издевается тут :p
вот начало


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
новую игрушку нашел

не , сам подбросил и издевается тут :p
вот начало

Автор - китин
Дата добавления - 14.06.2016 в 11:46
SkyPro Дата: Вторник, 14.06.2016, 13:47 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1206
Репутация: 253 ±
Замечаний: 0% ±

2010
Еще вариант ничего в файлах не меняя

_Boroda_, Саша, у меня что-то твой вариант при протягивании не считает )
[moder]Покажи[/moder]


Тянул с С19

Автопересчет включен.
К сообщению приложен файл: 0081204.gif(66Kb) · -1-1-3-.xlsx(11Kb)


skypro1111@gmail.com

Сообщение отредактировал SkyPro - Вторник, 14.06.2016, 14:25
 
Ответить
Сообщение
Еще вариант ничего в файлах не меняя

_Boroda_, Саша, у меня что-то твой вариант при протягивании не считает )
[moder]Покажи[/moder]


Тянул с С19

Автопересчет включен.

Автор - SkyPro
Дата добавления - 14.06.2016 в 13:47
китин Дата: Вторник, 14.06.2016, 14:03 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
что-то твой вариант при протягивании не считает

считает у меня


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
что-то твой вариант при протягивании не считает

считает у меня

Автор - китин
Дата добавления - 14.06.2016 в 14:03
SkyPro Дата: Вторник, 14.06.2016, 14:40 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1206
Репутация: 253 ±
Замечаний: 0% ±

2010
Разобрался )
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$12;"MYYY")=B$17&МАКС($B$16:B$16))*$C$3:$C$12*($B$3:$B$12=$A19))

У меня ТЕКСТ просит латиницу.


skypro1111@gmail.com
 
Ответить
СообщениеРазобрался )
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$12;"MYYY")=B$17&МАКС($B$16:B$16))*$C$3:$C$12*($B$3:$B$12=$A19))

У меня ТЕКСТ просит латиницу.

Автор - SkyPro
Дата добавления - 14.06.2016 в 14:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из плоского списка разнести согласно месяцам и годам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!