Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как протянуть через строку формулу? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как протянуть через строку формулу? (Формулы/Formulas)
Как протянуть через строку формулу?
Alboy Дата: Среда, 29.06.2016, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Как протянуть через строку формулу?
Суть проблемы:
если в ячейки вбить значения 1, потом пустоту, затем 2, потом пустоту, и потом протянуть эти 4 ячейки, получится нужный результат (5 ячейка примет значение 3, 6-ая пустоту, 7-ая значение 4)

Нужно сделать тоже самое, но для формул.
Если задать что A1 = C1, A2 пустая, A3 = C2, A4 пустая и выделить ячейки от A1 до A4 и протянуть вниз, хотелось бы чтобы ячейка A5 приняла значение C3, а она принимает значение A5.
 
Ответить
СообщениеКак протянуть через строку формулу?
Суть проблемы:
если в ячейки вбить значения 1, потом пустоту, затем 2, потом пустоту, и потом протянуть эти 4 ячейки, получится нужный результат (5 ячейка примет значение 3, 6-ая пустоту, 7-ая значение 4)

Нужно сделать тоже самое, но для формул.
Если задать что A1 = C1, A2 пустая, A3 = C2, A4 пустая и выделить ячейки от A1 до A4 и протянуть вниз, хотелось бы чтобы ячейка A5 приняла значение C3, а она принимает значение A5.

Автор - Alboy
Дата добавления - 29.06.2016 в 11:47
китин Дата: Среда, 29.06.2016, 11:55 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а файл?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа файл?

Автор - китин
Дата добавления - 29.06.2016 в 11:55
Alboy Дата: Среда, 29.06.2016, 12:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
прикрепил, информация берется с листа 3 для листа 2
К сообщению приложен файл: _-3-.xls(38Kb)
 
Ответить
Сообщениеприкрепил, информация берется с листа 3 для листа 2

Автор - Alboy
Дата добавления - 29.06.2016 в 12:00
Manyasha Дата: Среда, 29.06.2016, 12:06 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Alboy, в строке 5 и 7 ошибка?
Посмотрите такой вариант
Код
=ИНДЕКС(Лист3!$A$2:$A$100;ОКРУГЛВВЕРХ(СТРОКА(A1)/2;))

или
Код
=ЕСЛИ(ЕНЕЧЁТ(СТРОКА());ИНДЕКС(Лист3!$A$2:$A$100;ОКРУГЛВВЕРХ(СТРОКА(A1)/2;));"")

1й варийан - протягиваем 2 ячейки (с формулой и пустую)
2й - протягиваем только первую.
UPD
что-то я перемудрила...Не нужно ОТБР. Формулы поправила, файл перезалила
К сообщению приложен файл: -3-1.xls(46Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Среда, 29.06.2016, 12:38
 
Ответить
СообщениеAlboy, в строке 5 и 7 ошибка?
Посмотрите такой вариант
Код
=ИНДЕКС(Лист3!$A$2:$A$100;ОКРУГЛВВЕРХ(СТРОКА(A1)/2;))

или
Код
=ЕСЛИ(ЕНЕЧЁТ(СТРОКА());ИНДЕКС(Лист3!$A$2:$A$100;ОКРУГЛВВЕРХ(СТРОКА(A1)/2;));"")

1й варийан - протягиваем 2 ячейки (с формулой и пустую)
2й - протягиваем только первую.
UPD
что-то я перемудрила...Не нужно ОТБР. Формулы поправила, файл перезалила

Автор - Manyasha
Дата добавления - 29.06.2016 в 12:06
abtextime Дата: Среда, 29.06.2016, 12:07 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;2))
К сообщению приложен файл: -3-.xls(45Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;2))

Автор - abtextime
Дата добавления - 29.06.2016 в 12:07
китин Дата: Среда, 29.06.2016, 12:08 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну вот так примерно
Код
=ЕСЛИ(ОСТАТ((СТРОКА(A1)-1)/2+1;1)=0;ИНДЕКС(Лист3!A$2:A$17;(СТРОКА(A1)-1)/2+1);"")
К сообщению приложен файл: 333.xlsx(24Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 29.06.2016, 12:14
 
Ответить
Сообщениену вот так примерно
Код
=ЕСЛИ(ОСТАТ((СТРОКА(A1)-1)/2+1;1)=0;ИНДЕКС(Лист3!A$2:A$17;(СТРОКА(A1)-1)/2+1);"")

Автор - китин
Дата добавления - 29.06.2016 в 12:08
abtextime Дата: Среда, 29.06.2016, 12:14 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Зачем Вы вводите в заблуждение? У Вас же на Листе2 артикулы не такие же, как на Листе3. Так всё же - артикулы Листа2 в точности соответствуют списку артикулов на Листе3 или нет? Если нет, то
[s][code]
=ЕСЛИОШИБКА(ВПР(A1;Лист3!$A$2:$C$17;3;0);"")[/code
[/s]]

Упс, заблудился
К сообщению приложен файл: 5722455.xls(46Kb)


Сообщение отредактировал abtextime - Среда, 29.06.2016, 12:20
 
Ответить
СообщениеЗачем Вы вводите в заблуждение? У Вас же на Листе2 артикулы не такие же, как на Листе3. Так всё же - артикулы Листа2 в точности соответствуют списку артикулов на Листе3 или нет? Если нет, то
[s][code]
=ЕСЛИОШИБКА(ВПР(A1;Лист3!$A$2:$C$17;3;0);"")[/code
[/s]]

Упс, заблудился

Автор - abtextime
Дата добавления - 29.06.2016 в 12:14
китин Дата: Среда, 29.06.2016, 12:19 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеТут тоже помогают

Автор - китин
Дата добавления - 29.06.2016 в 12:19
abtextime Дата: Среда, 29.06.2016, 12:26 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Кароч, так у меня получилось, хз

в A1

Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;0))


в B1
Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;2))

или
Код
=ЕСЛИОШИБКА(ВПР(A1;Лист3!$A$2:$C$17;3;0);"")
К сообщению приложен файл: 4395575.xls(46Kb)


Сообщение отредактировал abtextime - Среда, 29.06.2016, 12:26
 
Ответить
СообщениеКароч, так у меня получилось, хз

в A1

Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;0))


в B1
Код
=ЕСЛИ(ЕЧЁТН(СТРОКА());"";СМЕЩ(Лист3!A2;-СТРОКА()/2;2))

или
Код
=ЕСЛИОШИБКА(ВПР(A1;Лист3!$A$2:$C$17;3;0);"")

Автор - abtextime
Дата добавления - 29.06.2016 в 12:26
abtextime Дата: Среда, 29.06.2016, 12:31 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Alboy

А название темы исправьте лучше, оно не соответствует правилам Форума (не описывает более-менее чётко задачу), модератор может заблокировать ответы в тему до ее исправления
 
Ответить
СообщениеAlboy

А название темы исправьте лучше, оно не соответствует правилам Форума (не описывает более-менее чётко задачу), модератор может заблокировать ответы в тему до ее исправления

Автор - abtextime
Дата добавления - 29.06.2016 в 12:31
Alboy Дата: Среда, 29.06.2016, 12:32 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
спасибо, подошло, больше всех вариант Manyasha
[moder]Посмотрите еще раз мой пост, я его обновила[/moder]


Сообщение отредактировал Manyasha - Среда, 29.06.2016, 12:38
 
Ответить
Сообщениеспасибо, подошло, больше всех вариант Manyasha
[moder]Посмотрите еще раз мой пост, я его обновила[/moder]

Автор - Alboy
Дата добавления - 29.06.2016 в 12:32
Alboy Дата: Среда, 29.06.2016, 13:11 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Модератор:
Посмотрите еще раз мой пост, я его обновила

Что не так в названии темы?
[moder]В моем посте нет ничего про название, формулы смотрите, я их поправила.[/moder]


Сообщение отредактировал Manyasha - Среда, 29.06.2016, 13:15
 
Ответить
Сообщение
Модератор:
Посмотрите еще раз мой пост, я его обновила

Что не так в названии темы?
[moder]В моем посте нет ничего про название, формулы смотрите, я их поправила.[/moder]

Автор - Alboy
Дата добавления - 29.06.2016 в 13:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как протянуть через строку формулу? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!