Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/НУмерация по заданному набору условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » НУмерация по заданному набору условий (Формулы/Formulas)
НУмерация по заданному набору условий
AlekseyM Дата: Вторник, 13.09.2016, 09:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро!
Есть файл с городами. Нужно присвоить одинаковым городам одинаковый номер. При этом. если статус города становится ВЫБЫЛ, то такой город не нумеруется.
Помогите пожалуйста.
К сообщению приложен файл: _Microsoft_Exce.xlsx(9Kb)
 
Ответить
СообщениеДоброе утро!
Есть файл с городами. Нужно присвоить одинаковым городам одинаковый номер. При этом. если статус города становится ВЫБЫЛ, то такой город не нумеруется.
Помогите пожалуйста.

Автор - AlekseyM
Дата добавления - 13.09.2016 в 09:41
Pelena Дата: Вторник, 13.09.2016, 09:55 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если правильно поняла
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИОШИБКА(ВПР(C2;$C$1:$D1;2;0);МАКС($D$1:D1)+1))
К сообщению приложен файл: 4726615.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИОШИБКА(ВПР(C2;$C$1:$D1;2;0);МАКС($D$1:D1)+1))

Автор - Pelena
Дата добавления - 13.09.2016 в 09:55
китин Дата: Вторник, 13.09.2016, 09:58 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4096
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам доброго. как то так похоже
Код
=СУММПРОИЗВ(($C$2:C2=C2)*($B$2:B2<>"выбыл"))

не так понял :'(
К сообщению приложен файл: 222111.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 13.09.2016, 10:01
 
Ответить
Сообщениеи вам доброго. как то так похоже
Код
=СУММПРОИЗВ(($C$2:C2=C2)*($B$2:B2<>"выбыл"))

не так понял :'(

Автор - китин
Дата добавления - 13.09.2016 в 09:58
Roman777 Дата: Вторник, 13.09.2016, 10:18 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 81 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
AlekseyM,
или чуть модифицировал (или угробил? ) форумулу Pelena,
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИОШИБКА(ЕСЛИ(ВПР(C2;$C$1:$D1;2;0)="";МАКС($D$1:$D1)+1;ВПР(C2;$C$1:$D1;2;0));МАКС($D$1:$D1)+1))

не, не работает как надо


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Вторник, 13.09.2016, 10:32
 
Ответить
СообщениеAlekseyM,
или чуть модифицировал (или угробил? ) форумулу Pelena,
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИОШИБКА(ЕСЛИ(ВПР(C2;$C$1:$D1;2;0)="";МАКС($D$1:$D1)+1;ВПР(C2;$C$1:$D1;2;0));МАКС($D$1:$D1)+1))

не, не работает как надо

Автор - Roman777
Дата добавления - 13.09.2016 в 10:18
AlekseyM Дата: Вторник, 13.09.2016, 10:32 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Последняя формула правильно работает. Спасибо большое!!!
 
Ответить
СообщениеПоследняя формула правильно работает. Спасибо большое!!!

Автор - AlekseyM
Дата добавления - 13.09.2016 в 10:32
Roman777 Дата: Вторник, 13.09.2016, 10:43 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 81 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
AlekseyM, отмечу что работает она всё-таки неправильно. И честно говоря, не догоняю пока как её формулами сделать правильно.
К сообщению приложен файл: 3991000.xlsx(10Kb)


Много чего не знаю!!!!
 
Ответить
СообщениеAlekseyM, отмечу что работает она всё-таки неправильно. И честно говоря, не догоняю пока как её формулами сделать правильно.

Автор - Roman777
Дата добавления - 13.09.2016 в 10:43
_Boroda_ Дата: Вторник, 13.09.2016, 10:52 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В условии ничего не сказано об последовательности чисел. Тогда можно вот так, например
Код
=ЕСЛИ(B2="выбыл";"";СЧЁТЕСЛИМН(C$2:C$8;">="&C2))
К сообщению приложен файл: 3991000_2.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ условии ничего не сказано об последовательности чисел. Тогда можно вот так, например
Код
=ЕСЛИ(B2="выбыл";"";СЧЁТЕСЛИМН(C$2:C$8;">="&C2))

Автор - _Boroda_
Дата добавления - 13.09.2016 в 10:52
Pelena Дата: Вторник, 13.09.2016, 11:03 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Такой ещё вариант
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;C2)*СУММЕСЛИ($C$1:C1;C2;$D$1:D1);ПРОСМОТР(2;1/(C2=$C$1:$C1);$D$1:D1);МАКС($D$1:D1)+1))
К сообщению приложен файл: 0780288.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТакой ещё вариант
Код
=ЕСЛИ(B2="выбыл";"";ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;C2)*СУММЕСЛИ($C$1:C1;C2;$D$1:D1);ПРОСМОТР(2;1/(C2=$C$1:$C1);$D$1:D1);МАКС($D$1:D1)+1))

Автор - Pelena
Дата добавления - 13.09.2016 в 11:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » НУмерация по заданному набору условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!