Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывод значений по заданному условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод значений по заданному условия (Формулы/Formulas)
вывод значений по заданному условия
miha_ Дата: Понедельник, 15.05.2017, 13:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,уважаемые форумчане. Помогите преобразовать формулу предложенную Nic70y,
Код
=НАИБОЛЬШИЙ(D$4:D$43;СЧЁТЕСЛИ(D$4:D$43;">="&F3)+1)
, таким образом, чтобы из столбца А выводились все значения, сумма которых по столбцу В равна 80% от суммы всех значений в столбце В. В столбце Н значения которые должны получиться. Формула должна быть протягиваемой. Спасибо.
К сообщению приложен файл: 1327658.xlsx(11Kb)
 
Ответить
СообщениеДобрый день,уважаемые форумчане. Помогите преобразовать формулу предложенную Nic70y,
Код
=НАИБОЛЬШИЙ(D$4:D$43;СЧЁТЕСЛИ(D$4:D$43;">="&F3)+1)
, таким образом, чтобы из столбца А выводились все значения, сумма которых по столбцу В равна 80% от суммы всех значений в столбце В. В столбце Н значения которые должны получиться. Формула должна быть протягиваемой. Спасибо.

Автор - miha_
Дата добавления - 15.05.2017 в 13:04
Nic70y Дата: Понедельник, 15.05.2017, 13:20 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4238
Репутация: 922 ±
Замечаний: 0% ±

Excel 2013
сумма которых по столбцу В равна 80% от суммы всех значений в столбце В. В
в файле не обнаружено.
уточните пжл задачу
К сообщению приложен файл: 5536365.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
сумма которых по столбцу В равна 80% от суммы всех значений в столбце В. В
в файле не обнаружено.
уточните пжл задачу

Автор - Nic70y
Дата добавления - 15.05.2017 в 13:20
sboy Дата: Понедельник, 15.05.2017, 13:20 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
из серии "вдруг угадал"
Код
=Таблица1[@Столбец1]*(СУММ($B$2:B2)<=СУММ((Таблица1[Столбец2]))*0,8)

[p.s.]Зачем Вы хотите использовать функцию НАИБОЛЬШИЙ, если значения уже отсортированы?
К сообщению приложен файл: 6146900.xlsx(12Kb)
 
Ответить
СообщениеДобрый день.
из серии "вдруг угадал"
Код
=Таблица1[@Столбец1]*(СУММ($B$2:B2)<=СУММ((Таблица1[Столбец2]))*0,8)

[p.s.]Зачем Вы хотите использовать функцию НАИБОЛЬШИЙ, если значения уже отсортированы?

Автор - sboy
Дата добавления - 15.05.2017 в 13:20
miha_ Дата: Понедельник, 15.05.2017, 13:28 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, все отлично если значения отсортированы по убыванию.Если нет , то и нет ожидаемого результата. В примере я отсортировал с той целью чтобы мог показать какие значения нужны.
 
Ответить
Сообщениеsboy, все отлично если значения отсортированы по убыванию.Если нет , то и нет ожидаемого результата. В примере я отсортировал с той целью чтобы мог показать какие значения нужны.

Автор - miha_
Дата добавления - 15.05.2017 в 13:28
sboy Дата: Понедельник, 15.05.2017, 13:43 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Вариант с доп.столбцом
нули и ошибки можно дополнительно обработать
Код
=ИНДЕКС(Таблица1[Столбец1];ПОИСКПОЗ(НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(A1));Таблица1[Столбец2];))*(СУММ($E$2:E2)<=СУММ((Таблица1[Столбец2]))*0,8)
К сообщению приложен файл: 2670890.xlsx(12Kb)
 
Ответить
СообщениеВариант с доп.столбцом
нули и ошибки можно дополнительно обработать
Код
=ИНДЕКС(Таблица1[Столбец1];ПОИСКПОЗ(НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(A1));Таблица1[Столбец2];))*(СУММ($E$2:E2)<=СУММ((Таблица1[Столбец2]))*0,8)

Автор - sboy
Дата добавления - 15.05.2017 в 13:43
miha_ Дата: Понедельник, 15.05.2017, 13:43 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, в примере постарался более подробно изложить суть вопроса.
Каждому значению из столбца А соответствует своё значение из столбца В, пр. А2 12589370 В2 1 254 825. В столбец Н необходимо выводить числовые значения из столбца А, при условии что соответствующие значения из столбца В входит в диапазон суммы(сумма значений из столбца В равна 80% от суммы всех значений столбца В).
Т.е. вывести значения по принципу ПАРРЕТО, 20% значений из столбца А дающие сумму в 80% по столбцу В (наибольшие значения).
К сообщению приложен файл: 4532255.xlsx(12Kb)
 
Ответить
СообщениеNic70y, в примере постарался более подробно изложить суть вопроса.
Каждому значению из столбца А соответствует своё значение из столбца В, пр. А2 12589370 В2 1 254 825. В столбец Н необходимо выводить числовые значения из столбца А, при условии что соответствующие значения из столбца В входит в диапазон суммы(сумма значений из столбца В равна 80% от суммы всех значений столбца В).
Т.е. вывести значения по принципу ПАРРЕТО, 20% значений из столбца А дающие сумму в 80% по столбцу В (наибольшие значения).

Автор - miha_
Дата добавления - 15.05.2017 в 13:43
miha_ Дата: Понедельник, 15.05.2017, 13:47 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, в примере постарался более подробно изложить суть вопроса.
Каждому значению из столбца А соответствует своё значение из столбца В, пр. А2 12589370 В2 1 254 825. В столбец Н необходимо выводить числовые значения из столбца А, при условии что соответствующие значения из столбца В входит в диапазон суммы(сумма значений из столбца В равна 80% от суммы всех значений столбца В).
Т.е. вывести значения по принципу ПАРРЕТО, 20% значений из столбца А дающие сумму в 80% по столбцу В (наибольшие значения).
К сообщению приложен файл: 1316608.xlsx(12Kb)
 
Ответить
СообщениеNic70y, в примере постарался более подробно изложить суть вопроса.
Каждому значению из столбца А соответствует своё значение из столбца В, пр. А2 12589370 В2 1 254 825. В столбец Н необходимо выводить числовые значения из столбца А, при условии что соответствующие значения из столбца В входит в диапазон суммы(сумма значений из столбца В равна 80% от суммы всех значений столбца В).
Т.е. вывести значения по принципу ПАРРЕТО, 20% значений из столбца А дающие сумму в 80% по столбцу В (наибольшие значения).

Автор - miha_
Дата добавления - 15.05.2017 в 13:47
Nic70y Дата: Понедельник, 15.05.2017, 16:43 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4238
Репутация: 922 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(СУММ(I$1:I1)>=0,8*Таблица1[[#Итоги];[Столбец2]];ЕСЛИ(ЕНД(ПОИСКПОЗ(I1;Таблица1[Столбец2];));"";СУММ(I$1:I1));НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(D1)))
тег глюканул
Цитата
=ЕСЛИ(СУММ(I$1:I1)>=0,8*Таблица1[[#Итоги];[Столбец2]];ЕСЛИ(ЕНД(ПОИСКПОЗ(I1;Таблица1[Столбец2];));"";СУММ(I$1:I1));НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(D1)))
К сообщению приложен файл: 17-24-65.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 15.05.2017, 16:47
 
Ответить
Сообщение
Код
=ЕСЛИ(СУММ(I$1:I1)>=0,8*Таблица1[[#Итоги];[Столбец2]];ЕСЛИ(ЕНД(ПОИСКПОЗ(I1;Таблица1[Столбец2];));"";СУММ(I$1:I1));НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(D1)))
тег глюканул
Цитата
=ЕСЛИ(СУММ(I$1:I1)>=0,8*Таблица1[[#Итоги];[Столбец2]];ЕСЛИ(ЕНД(ПОИСКПОЗ(I1;Таблица1[Столбец2];));"";СУММ(I$1:I1));НАИБОЛЬШИЙ(Таблица1[Столбец2];СТРОКА(D1)))

Автор - Nic70y
Дата добавления - 15.05.2017 в 16:43
miha_ Дата: Понедельник, 15.05.2017, 17:12 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, спасибо. прекрасное решение.сейчас буду разбираться с алгоритмом.
 
Ответить
СообщениеNic70y, спасибо. прекрасное решение.сейчас буду разбираться с алгоритмом.

Автор - miha_
Дата добавления - 15.05.2017 в 17:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод значений по заданному условия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!