Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление горизонтального и вертикального массива данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление горизонтального и вертикального массива данных (Формулы/Formulas)
Сопоставление горизонтального и вертикального массива данных
artemn Дата: Среда, 12.07.2017, 19:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте!
Скажите, пожалуйста, возможно ли с помощью формулы или макроса выполнить следующие действия?
В приложении пример.
На листе 2 есть массив кодов в первом столбце (код). На листе 1 находится таблица, где в верхней строк указаны коды из таблицы листа 2, а в первом столбце указаны коды, которые сопоставимы с кодами в строках. Необходимо осуществить поиск кода из столбца 1 листа 2 в верхней строке листа 1, а при совпадении скопировать коды из столбца 1 листа 1 в столбец 2 листа 2. Желаемый результат видно на листе 2.
Покажите, пожалуйста, как это сделать, очень прошу.
К сообщению приложен файл: 9387961.xlsx(11Kb)


Сообщение отредактировал artemn - Четверг, 13.07.2017, 09:55
 
Ответить
СообщениеЗдравствуйте!
Скажите, пожалуйста, возможно ли с помощью формулы или макроса выполнить следующие действия?
В приложении пример.
На листе 2 есть массив кодов в первом столбце (код). На листе 1 находится таблица, где в верхней строк указаны коды из таблицы листа 2, а в первом столбце указаны коды, которые сопоставимы с кодами в строках. Необходимо осуществить поиск кода из столбца 1 листа 2 в верхней строке листа 1, а при совпадении скопировать коды из столбца 1 листа 1 в столбец 2 листа 2. Желаемый результат видно на листе 2.
Покажите, пожалуйста, как это сделать, очень прошу.

Автор - artemn
Дата добавления - 12.07.2017 в 19:39
vikttur Дата: Среда, 12.07.2017, 20:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2394
Репутация: 413 ±
Замечаний: 0% ±

Надо не убегать сразу, а проверить созданное сообщение. Нет вложения.
 
Ответить
СообщениеНадо не убегать сразу, а проверить созданное сообщение. Нет вложения.

Автор - vikttur
Дата добавления - 12.07.2017 в 20:04
artemn Дата: Четверг, 13.07.2017, 09:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Надо не убегать сразу, а проверить созданное сообщение. Нет вложения.


Спасибо. Теперь прикрепил
 
Ответить
Сообщение
Надо не убегать сразу, а проверить созданное сообщение. Нет вложения.


Спасибо. Теперь прикрепил

Автор - artemn
Дата добавления - 13.07.2017 в 09:56
vikttur Дата: Четверг, 13.07.2017, 10:07 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2394
Репутация: 413 ±
Замечаний: 0% ±

Если кодов много, то нужно макросом.
 
Ответить
СообщениеЕсли кодов много, то нужно макросом.

Автор - vikttur
Дата добавления - 13.07.2017 в 10:07
sboy Дата: Четверг, 13.07.2017, 11:05 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант формулой по столбцам. потом можно сцепить в одну ячейку
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$A$2:$A$6;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$6)-1)/ЕТЕКСТ(ИНДЕКС(Sheet1!$B$2:$E$6;;ПОИСКПОЗ($A2;Sheet1!$B$1:$E$1;)));СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 1290124.xlsx(11Kb)
 
Ответить
СообщениеДобрый день.
Вариант формулой по столбцам. потом можно сцепить в одну ячейку
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$A$2:$A$6;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$6)-1)/ЕТЕКСТ(ИНДЕКС(Sheet1!$B$2:$E$6;;ПОИСКПОЗ($A2;Sheet1!$B$1:$E$1;)));СТОЛБЕЦ(A1)));"")

Автор - sboy
Дата добавления - 13.07.2017 в 11:05
artemn Дата: Четверг, 13.07.2017, 18:42 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
sboy, спасибо!
Вроде все повторил, но результата нет. Посмотрите, пожалуйста, в чем ошибка? приложил файл
К сообщению приложен файл: Example1.xlsx(74Kb)
 
Ответить
Сообщениеsboy, спасибо!
Вроде все повторил, но результата нет. Посмотрите, пожалуйста, в чем ошибка? приложил файл

Автор - artemn
Дата добавления - 13.07.2017 в 18:42
Pelena Дата: Четверг, 13.07.2017, 19:32 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11481
Репутация: 2549 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Вроде все повторил

не совсем
Код
=ЕСЛИОШИБКА(ИНДЕКС('EOS Body compatibility'!$A$2:$A$84;АГРЕГАТ(15;6;(СТРОКА('EOS Body compatibility'!$A$2:$A$84)-1)/ЕТЕКСТ(ИНДЕКС('EOS Body compatibility'!$B$2:$BY$84;;ПОИСКПОЗ($A2;'EOS Body compatibility'!$B$1:$BY$1;)));СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 3668530.xlsx(92Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Вроде все повторил

не совсем
Код
=ЕСЛИОШИБКА(ИНДЕКС('EOS Body compatibility'!$A$2:$A$84;АГРЕГАТ(15;6;(СТРОКА('EOS Body compatibility'!$A$2:$A$84)-1)/ЕТЕКСТ(ИНДЕКС('EOS Body compatibility'!$B$2:$BY$84;;ПОИСКПОЗ($A2;'EOS Body compatibility'!$B$1:$BY$1;)));СТОЛБЕЦ(A1)));"")

Автор - Pelena
Дата добавления - 13.07.2017 в 19:32
artemn Дата: Среда, 19.07.2017, 12:59 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
не совсем

=ЕСЛИОШИБКА(ИНДЕКС('EOS Body compatibility'!$A$2:$A$84;АГРЕГАТ(15;6;(СТРОКА('EOS Body compatibility'!$A$2:$A$84)-1)/ЕТЕКСТ(ИНДЕКС('EOS Body compatibility'!$B$2:$BY$84;;ПОИСКПОЗ($A2;'EOS Body compatibility'!$B$1:$BY$1;)));СТОЛБЕЦ(A1)));"")


Я сейчас с ума сойду. Не получается. Формулы правильно перевел, строки правильно указал. Что не так, скажите, пожалуйста.
К сообщению приложен файл: Example_3.xlsx(81Kb)
 
Ответить
Сообщение
не совсем

=ЕСЛИОШИБКА(ИНДЕКС('EOS Body compatibility'!$A$2:$A$84;АГРЕГАТ(15;6;(СТРОКА('EOS Body compatibility'!$A$2:$A$84)-1)/ЕТЕКСТ(ИНДЕКС('EOS Body compatibility'!$B$2:$BY$84;;ПОИСКПОЗ($A2;'EOS Body compatibility'!$B$1:$BY$1;)));СТОЛБЕЦ(A1)));"")


Я сейчас с ума сойду. Не получается. Формулы правильно перевел, строки правильно указал. Что не так, скажите, пожалуйста.

Автор - artemn
Дата добавления - 19.07.2017 в 12:59
sboy Дата: Среда, 19.07.2017, 13:15 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
artemn, Елена Вам же указала на ошибки.
Вот кусок, где у Вас неправильно
Код
ПОИСКПОЗ($A1;'EOS Body compatibility'!$B$2:$AO$93;)));СТРОКА(A1))

а вот правильно
Код
ПОИСКПОЗ($A1;'EOS Body compatibility'!$B$1:$AO$1;)));СТОЛБЕЦ(A1))

[p.s.] и подкорректируйте свое сообщение, излишнее цитирование запрещено
К сообщению приложен файл: 0609886.xlsx(85Kb)


Сообщение отредактировал sboy - Среда, 19.07.2017, 13:16
 
Ответить
Сообщениеartemn, Елена Вам же указала на ошибки.
Вот кусок, где у Вас неправильно
Код
ПОИСКПОЗ($A1;'EOS Body compatibility'!$B$2:$AO$93;)));СТРОКА(A1))

а вот правильно
Код
ПОИСКПОЗ($A1;'EOS Body compatibility'!$B$1:$AO$1;)));СТОЛБЕЦ(A1))

[p.s.] и подкорректируйте свое сообщение, излишнее цитирование запрещено

Автор - sboy
Дата добавления - 19.07.2017 в 13:15
artemn Дата: Среда, 19.07.2017, 16:29 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Елена Вам же указала на ошибки.
Вот кусок, где у Вас неправильно


Спасибо. Все получилось

[moder]Замечание. Систематическое нарушение п. 5j Правил форума[/moder]


Сообщение отредактировал _Boroda_ - Среда, 19.07.2017, 16:48
 
Ответить
Сообщение
Елена Вам же указала на ошибки.
Вот кусок, где у Вас неправильно


Спасибо. Все получилось

[moder]Замечание. Систематическое нарушение п. 5j Правил форума[/moder]

Автор - artemn
Дата добавления - 19.07.2017 в 16:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление горизонтального и вертикального массива данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!