Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт ячеек между одинаковыми числами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек между одинаковыми числами (Формулы/Formulas)
Подсчёт ячеек между одинаковыми числами
Qualcomm Дата: Понедельник, 24.07.2017, 18:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Помогите пожалуйста с формулой, которая считает количество ячеек между числом равному этому и выше. В прикрепленном файле в столбце С, то что требуется, то есть количество ячеек между повторяющимися числами, которые равны ему или выше. Например число 4, формулой нужно посчитать через сколько ячеек будет снова число 4, либо число выше 4 (5,6,7,8,9, и т.п.) В столбце Е я прописал ячейку в которой как раз это первое повторение встречается, это чисто для понимания задачи. Основная цель это столбец С. Буду очень признателен за помощь.
К сообщению приложен файл: 0426543.xlsx(16Kb)
 
Ответить
СообщениеПомогите пожалуйста с формулой, которая считает количество ячеек между числом равному этому и выше. В прикрепленном файле в столбце С, то что требуется, то есть количество ячеек между повторяющимися числами, которые равны ему или выше. Например число 4, формулой нужно посчитать через сколько ячеек будет снова число 4, либо число выше 4 (5,6,7,8,9, и т.п.) В столбце Е я прописал ячейку в которой как раз это первое повторение встречается, это чисто для понимания задачи. Основная цель это столбец С. Буду очень признателен за помощь.

Автор - Qualcomm
Дата добавления - 24.07.2017 в 18:59
vikttur Дата: Понедельник, 24.07.2017, 19:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2313
Репутация: 401 ±
Замечаний: 0% ±

Уберите три ошибки в конце диапазона в столбце В.
В столбце В много мусора - в "пустых" ячейках не пусто. Из-за этого в формуле добавлены проверки.
Формула массива (ввод тремя клавишами):
Код
=ЕСЛИ(ЕЧИСЛО(B2);МИН(ЕЧИСЛО(B3:$B$427);ЕСЛИ(B3:$B$427>=B2;СТРОКА(B3:$B$427)))-СТРОКА();)

Лишние нули можно скрыть в параметрах листа.
К сообщению приложен файл: 8196128.xlsx(10Kb)


Сообщение отредактировал vikttur - Понедельник, 24.07.2017, 20:00
 
Ответить
СообщениеУберите три ошибки в конце диапазона в столбце В.
В столбце В много мусора - в "пустых" ячейках не пусто. Из-за этого в формуле добавлены проверки.
Формула массива (ввод тремя клавишами):
Код
=ЕСЛИ(ЕЧИСЛО(B2);МИН(ЕЧИСЛО(B3:$B$427);ЕСЛИ(B3:$B$427>=B2;СТРОКА(B3:$B$427)))-СТРОКА();)

Лишние нули можно скрыть в параметрах листа.

Автор - vikttur
Дата добавления - 24.07.2017 в 19:53
Qualcomm Дата: Понедельник, 24.07.2017, 20:28 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
vikttur, протянул формулу до конца, формула почему-то стала считать некорректно (
К сообщению приложен файл: 3591484.xlsx(20Kb)
 
Ответить
Сообщениеvikttur, протянул формулу до конца, формула почему-то стала считать некорректно (

Автор - Qualcomm
Дата добавления - 24.07.2017 в 20:28
Nic70y Дата: Понедельник, 24.07.2017, 20:42 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4045
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
Код
=МАКС(МИН(ЕСЛИ(ЕСЛИОШИБКА(B3:$B$244/1;0)>=B2;СТРОКА(B3:$B$244)))-СТРОКА();0)
Код
=ЕЧИСЛО(B2)*МАКС(МИН(ЕСЛИ(ЕСЛИОШИБКА(B3:$B$244/1;0)>=B2;СТРОКА(B3:$B$244)))-СТРОКА();0)
К сообщению приложен файл: 6363739.xlsx(20Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 24.07.2017, 20:49
 
Ответить
Сообщение
Код
=МАКС(МИН(ЕСЛИ(ЕСЛИОШИБКА(B3:$B$244/1;0)>=B2;СТРОКА(B3:$B$244)))-СТРОКА();0)
Код
=ЕЧИСЛО(B2)*МАКС(МИН(ЕСЛИ(ЕСЛИОШИБКА(B3:$B$244/1;0)>=B2;СТРОКА(B3:$B$244)))-СТРОКА();0)

Автор - Nic70y
Дата добавления - 24.07.2017 в 20:42
Qualcomm Дата: Понедельник, 24.07.2017, 21:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, а возможно каким-нибудь образом вычитать из получаемого формулой числа то число до которого велся подсчет? на примере ячейки С26, я там вычел ту ячейку до которой считала формула
К сообщению приложен файл: 0976821.xlsx(20Kb)
 
Ответить
СообщениеNic70y, а возможно каким-нибудь образом вычитать из получаемого формулой числа то число до которого велся подсчет? на примере ячейки С26, я там вычел ту ячейку до которой считала формула

Автор - Qualcomm
Дата добавления - 24.07.2017 в 21:20
_Boroda_ Дата: Понедельник, 24.07.2017, 21:56 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
По начальному вопросу (ничего в файле не убирая)
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(B2);ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;);"");"")

По тому, который более потом
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(B2);ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;)-ИНДЕКС(B3:B$387;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;));"");"")
К сообщению приложен файл: 0976821_1.xlsx(33Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПо начальному вопросу (ничего в файле не убирая)
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(B2);ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;);"");"")

По тому, который более потом
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(B2);ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;)-ИНДЕКС(B3:B$387;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;));"");"")

Автор - _Boroda_
Дата добавления - 24.07.2017 в 21:56
Qualcomm Дата: Вторник, 25.07.2017, 00:08 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, всем огромное спасибо за помощь!!
 
Ответить
Сообщение_Boroda_, всем огромное спасибо за помощь!!

Автор - Qualcomm
Дата добавления - 25.07.2017 в 00:08
Qualcomm Дата: Вторник, 25.07.2017, 00:45 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, можно последний вопрос? а возможно задать в формуле условие что бы она искала только начиная с 7 например? то есть если в ячейке 1,2,3,4,5,6 она ничего не не отображала бы, а если 7,8,9 и выше уже начинала работать? то есть подсчет количества ячеек между повторениями начиная от 7 и выше??
 
Ответить
Сообщение_Boroda_, можно последний вопрос? а возможно задать в формуле условие что бы она искала только начиная с 7 например? то есть если в ячейке 1,2,3,4,5,6 она ничего не не отображала бы, а если 7,8,9 и выше уже начинала работать? то есть подсчет количества ячеек между повторениями начиная от 7 и выше??

Автор - Qualcomm
Дата добавления - 25.07.2017 в 00:45
_Boroda_ Дата: Вторник, 25.07.2017, 01:21 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(B2>6;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;)-ИНДЕКС(B3:B$387;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;));"");"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ЕСЛИОШИБКА(ЕСЛИ(B2>6;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;)-ИНДЕКС(B3:B$387;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--B3:B$387;)>=B2;));"");"")

Автор - _Boroda_
Дата добавления - 25.07.2017 в 01:21
Светлый Дата: Вторник, 25.07.2017, 08:20 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 291
Репутация: 72 ±
Замечаний: 0% ±

Excel 2007
В исходном файле в столбцах C и E есть ошибки. Мои формулы такие. Массивные.
Для C:
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B3:B999>=B2;))

Для E:
Код
=ЕСЛИ(B2="";"";ИНДЕКС(B3:B999;ПОИСКПОЗ(0=0;--B3:B999>=B2;)))

И по вопросу из 8 сообщения:
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B10:B1006>=B2;)+7)

Вернее
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B9:B1005>=B2;)+6)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 25.07.2017, 08:36
 
Ответить
СообщениеВ исходном файле в столбцах C и E есть ошибки. Мои формулы такие. Массивные.
Для C:
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B3:B999>=B2;))

Для E:
Код
=ЕСЛИ(B2="";"";ИНДЕКС(B3:B999;ПОИСКПОЗ(0=0;--B3:B999>=B2;)))

И по вопросу из 8 сообщения:
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B10:B1006>=B2;)+7)

Вернее
Код
=ЕСЛИ(B2="";"";ПОИСКПОЗ(0=0;--B9:B1005>=B2;)+6)

Автор - Светлый
Дата добавления - 25.07.2017 в 08:20
Qualcomm Дата: Вторник, 25.07.2017, 13:45 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, гениально! спасибо большое!
 
Ответить
Сообщение_Boroda_, гениально! спасибо большое!

Автор - Qualcomm
Дата добавления - 25.07.2017 в 13:45
Qualcomm Дата: Вторник, 25.07.2017, 13:45 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Светлый, спасибо большое!
 
Ответить
СообщениеСветлый, спасибо большое!

Автор - Qualcomm
Дата добавления - 25.07.2017 в 13:45
Qualcomm Дата: Вторник, 25.07.2017, 21:50 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, подскажите почему на первом листе формула считает корректно, но когда задаю доп условие (>7) вместо (>=D3) - это на втором листе, то формула считает всё подряд?
К сообщению приложен файл: 5829031.xlsx(83Kb)
 
Ответить
Сообщение_Boroda_, подскажите почему на первом листе формула считает корректно, но когда задаю доп условие (>7) вместо (>=D3) - это на втором листе, то формула считает всё подряд?

Автор - Qualcomm
Дата добавления - 25.07.2017 в 21:50
_Boroda_ Дата: Вторник, 25.07.2017, 21:59 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(D3)>7;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--D4:D$503;)>7;)-ИНДЕКС(D4:D$503;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--D4:D$503;)>7;));"");"")

У Вас там скорее всего была формула, возвращающая "". Затем Вы скопировали и вставили значениями. Визуально в ячейке пусто, в строке формул тоже пусто, но на самом деле - не пусто, а ""
Если Вы выделите все пустые ячейки столбца В и нажмете Делит, то вот тогда там станет действительно пусто
К сообщению приложен файл: 5829031_1.xlsx(88Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЕСЛИ(Ч(D3)>7;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--D4:D$503;)>7;)-ИНДЕКС(D4:D$503;ПОИСКПОЗ(1=1;ЕСЛИОШИБКА(--D4:D$503;)>7;));"");"")

У Вас там скорее всего была формула, возвращающая "". Затем Вы скопировали и вставили значениями. Визуально в ячейке пусто, в строке формул тоже пусто, но на самом деле - не пусто, а ""
Если Вы выделите все пустые ячейки столбца В и нажмете Делит, то вот тогда там станет действительно пусто

Автор - _Boroda_
Дата добавления - 25.07.2017 в 21:59
Qualcomm Дата: Вторник, 25.07.2017, 22:07 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, большое спасибо!! получается некорректная работа из-за того что было D3>7 вместо Ч(D3)>7 ?
 
Ответить
Сообщение_Boroda_, большое спасибо!! получается некорректная работа из-за того что было D3>7 вместо Ч(D3)>7 ?

Автор - Qualcomm
Дата добавления - 25.07.2017 в 22:07
_Boroda_ Дата: Вторник, 25.07.2017, 22:29 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Нет. Ч(D3)>7 мы просто заранее отрезаем расчет для пустышек. А было так
ЕСЛИОШИБКА(--B3:B$387;)>=B2 (числа сравниваем с пусто) всегда давало ЛОЖЬ, ПОИСКПОЗ давал ошибку и первая ЕСЛИОШИБКА обрабатывало ее как пусто
А когда Вы написали ЕСЛИОШИБКА(--D4:D$503;)>7, то мы числа стали сравнивать с числом и отсечение ошибок через ПОИСКПОЗ не прокатило


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНет. Ч(D3)>7 мы просто заранее отрезаем расчет для пустышек. А было так
ЕСЛИОШИБКА(--B3:B$387;)>=B2 (числа сравниваем с пусто) всегда давало ЛОЖЬ, ПОИСКПОЗ давал ошибку и первая ЕСЛИОШИБКА обрабатывало ее как пусто
А когда Вы написали ЕСЛИОШИБКА(--D4:D$503;)>7, то мы числа стали сравнивать с числом и отсечение ошибок через ПОИСКПОЗ не прокатило

Автор - _Boroda_
Дата добавления - 25.07.2017 в 22:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек между одинаковыми числами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!