Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формирование в порядке убывания по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формирование в порядке убывания по дате (Формулы/Formulas)
формирование в порядке убывания по дате
Nik57 Дата: Вторник, 27.02.2018, 13:54 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Друзья, помогите расположить диапазон P2:V36 расположить в порядке убывания, соответсвенно от даты и времени. Выборка - диапазон В2:Н36.
Через формулу НАИМЕНЬШИЙ я пробовал, почти получилось, но почему то там где в выборке пустые ячейки, в диапазоне P2:V36 аналогичные им ячейки выдают "ОШИБКУ".
Помогите кому не в лень)))
Что должно получиться это - так как прописано в диапазоне P2:V7, только его я прописал вручную.
К сообщению приложен файл: 5662508.xlsx(10.4 Kb)
 
Ответить
СообщениеДрузья, помогите расположить диапазон P2:V36 расположить в порядке убывания, соответсвенно от даты и времени. Выборка - диапазон В2:Н36.
Через формулу НАИМЕНЬШИЙ я пробовал, почти получилось, но почему то там где в выборке пустые ячейки, в диапазоне P2:V36 аналогичные им ячейки выдают "ОШИБКУ".
Помогите кому не в лень)))
Что должно получиться это - так как прописано в диапазоне P2:V7, только его я прописал вручную.

Автор - Nik57
Дата добавления - 27.02.2018 в 13:54
китин Дата: Вторник, 27.02.2018, 14:17 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5037
Репутация: 802 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствуте!!!
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$36;ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--($B$2:$B$36&ПСТР($C$2:$C$36;ПОИСК(",";$C$2:$C$36);10));"");СТРОКА(A1));--($B$2:$B$36&ПСТР($C$2:$C$36;ПОИСК(",";$C$2:$C$36);10));0));"")
К сообщению приложен файл: Nik57.xlsx(15.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам здравствуте!!!
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$36;ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--($B$2:$B$36&ПСТР($C$2:$C$36;ПОИСК(",";$C$2:$C$36);10));"");СТРОКА(A1));--($B$2:$B$36&ПСТР($C$2:$C$36;ПОИСК(",";$C$2:$C$36);10));0));"")

Автор - китин
Дата добавления - 27.02.2018 в 14:17
sboy Дата: Вторник, 27.02.2018, 15:07 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
вариант покороче (тоже массивная)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$H$36;ПОИСКПОЗ(АГРЕГАТ(14;6;1/($B$2:$B$36&$C$2:$C$36);СТРОКА(A1));1/($B$2:$B$36&$C$2:$C$36););СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 4176921.xlsx(15.7 Kb)
 
Ответить
СообщениеДобрый день.
вариант покороче (тоже массивная)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$H$36;ПОИСКПОЗ(АГРЕГАТ(14;6;1/($B$2:$B$36&$C$2:$C$36);СТРОКА(A1));1/($B$2:$B$36&$C$2:$C$36););СТОЛБЕЦ(A1));"")

Автор - sboy
Дата добавления - 27.02.2018 в 15:07
Nik57 Дата: Вторник, 27.02.2018, 15:09 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, спасибо, все работает как надо!)
 
Ответить
Сообщениекитин, спасибо, все работает как надо!)

Автор - Nik57
Дата добавления - 27.02.2018 в 15:09
Nik57 Дата: Воскресенье, 04.03.2018, 14:59 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, только есть одна проблемка в вашей формуле. Если дата и время полностью повторяются (к примеру В4:С5), то в диапазоне P3:V4 все значения дублируются по первому встречающемуся элементу.
К сообщению приложен файл: 7916365.xlsx(14.7 Kb)
 
Ответить
Сообщениекитин, только есть одна проблемка в вашей формуле. Если дата и время полностью повторяются (к примеру В4:С5), то в диапазоне P3:V4 все значения дублируются по первому встречающемуся элементу.

Автор - Nik57
Дата добавления - 04.03.2018 в 14:59
Nik57 Дата: Воскресенье, 04.03.2018, 15:00 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, если дату или время изменить в выборке, то требуемый диапазон вообще удаляется в вашем примере.
 
Ответить
Сообщениеsboy, если дату или время изменить в выборке, то требуемый диапазон вообще удаляется в вашем примере.

Автор - Nik57
Дата добавления - 04.03.2018 в 15:00
Nic70y Дата: Воскресенье, 04.03.2018, 15:45 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4802
Репутация: 1037 ±
Замечаний: 0% ±

Excel 2013
1 столб
Код
=ЕСЛИОШИБКА(ЦЕЛОЕ(НАИМЕНЬШИЙ($B$2:$B$36+$C$2:$C$36;СТРОКА(P1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36)));"")
2 столб
Код
=ЕСЛИОШИБКА(ОСТАТ(НАИМЕНЬШИЙ($B$2:$B$36+$C$2:$C$36;СТРОКА(Q1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36));1);"")
3 и правее
Код
=ЕСЛИ(P2="";"";ИНДЕКС(D$2:D$36;ПОИСКПОЗ($P2+$Q2;$B$2:$B$36+$C$2:$C$36;)))
К сообщению приложен файл: 0488681.xlsx(15.4 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение1 столб
Код
=ЕСЛИОШИБКА(ЦЕЛОЕ(НАИМЕНЬШИЙ($B$2:$B$36+$C$2:$C$36;СТРОКА(P1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36)));"")
2 столб
Код
=ЕСЛИОШИБКА(ОСТАТ(НАИМЕНЬШИЙ($B$2:$B$36+$C$2:$C$36;СТРОКА(Q1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36));1);"")
3 и правее
Код
=ЕСЛИ(P2="";"";ИНДЕКС(D$2:D$36;ПОИСКПОЗ($P2+$Q2;$B$2:$B$36+$C$2:$C$36;)))

Автор - Nic70y
Дата добавления - 04.03.2018 в 15:45
Nik57 Дата: Воскресенье, 04.03.2018, 15:58 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, так у вас таже самая ошибка. В Р4:V4 должна быть получиться строка В5:Н5. А строка Р4:V4 идентична Р3:V3
К сообщению приложен файл: 1581495.xlsx(15.5 Kb)
 
Ответить
СообщениеNic70y, так у вас таже самая ошибка. В Р4:V4 должна быть получиться строка В5:Н5. А строка Р4:V4 идентична Р3:V3

Автор - Nik57
Дата добавления - 04.03.2018 в 15:58
Nic70y Дата: Воскресенье, 04.03.2018, 16:09 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4802
Репутация: 1037 ±
Замечаний: 0% ±

Excel 2013
таже самая ошибка
ну вот и тупануть нельзя :)
Код
=ЕСЛИ(P2="";"";ИНДЕКС(D:D;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ($B$2:$B$36+СТРОКА($C$2:$C$36)/1000;СТРОКА(R1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36));1)*1000;)))
К сообщению приложен файл: 5549411.xlsx(15.3 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
таже самая ошибка
ну вот и тупануть нельзя :)
Код
=ЕСЛИ(P2="";"";ИНДЕКС(D:D;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ($B$2:$B$36+СТРОКА($C$2:$C$36)/1000;СТРОКА(R1)+СЧИТАТЬПУСТОТЫ($B$2:$B$36));1)*1000;)))

Автор - Nic70y
Дата добавления - 04.03.2018 в 16:09
Nik57 Дата: Воскресенье, 04.03.2018, 16:15 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, конечно можно, главное вовремя поправить!)) все работает, спасибо за помощь!)
 
Ответить
СообщениеNic70y, конечно можно, главное вовремя поправить!)) все работает, спасибо за помощь!)

Автор - Nik57
Дата добавления - 04.03.2018 в 16:15
Nic70y Дата: Воскресенье, 04.03.2018, 20:27 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4802
Репутация: 1037 ±
Замечаний: 0% ±

Excel 2013
все работает
да не, фигня какая-то (ибо не фиг на работе в эксель играться - работать надо)
в новом файле правильнее (наверное)

в файле 18-54 с допами, без массивных
К сообщению приложен файл: 6034051.xlsx(17.3 Kb) · 18-54.xlsx(13.7 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 04.03.2018, 20:57
 
Ответить
Сообщение
все работает
да не, фигня какая-то (ибо не фиг на работе в эксель играться - работать надо)
в новом файле правильнее (наверное)

в файле 18-54 с допами, без массивных

Автор - Nic70y
Дата добавления - 04.03.2018 в 20:27
Nik57 Дата: Вторник, 06.03.2018, 09:48 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, да, корректировка удачна))) использую ее, только что то без массивов формула не заработала, в столбце P ошибку выдает "ЧИСЛО". Хотя вроде и форматы те, все норм, но что то не так видимо сделал. Ну ладно, массивы главное работают))
 
Ответить
СообщениеNic70y, да, корректировка удачна))) использую ее, только что то без массивов формула не заработала, в столбце P ошибку выдает "ЧИСЛО". Хотя вроде и форматы те, все норм, но что то не так видимо сделал. Ну ладно, массивы главное работают))

Автор - Nik57
Дата добавления - 06.03.2018 в 09:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формирование в порядке убывания по дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!