Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти в строке "слово" и скопировать его и соседнюю строку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке "слово" и скопировать его и соседнюю строку (Формулы/Formulas)
Найти в строке "слово" и скопировать его и соседнюю строку
fokco Дата: Четверг, 29.10.2020, 08:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Есть строка с значениями. Надо в нем найти искомое слово и скопировать его в соседнюю строку .
Пример:
Есть слово яблоко надо его столбце и скопировать его и его соседа в соседние ячейки

пробовал так
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яблоко";A1:A8));"$A2=$C2")

Код
=ПСТР(A1;ПОИСК("яблоко";A8;1)+1;99)


ВРОДЕ нашел
Код
=ЕСЛИ(A2="яблоко";A2;"")

Код
=ЕСЛИ(A2="яблоко";B2;"")

Как их объединить ?
К сообщению приложен файл: 2951153.xlsx(8.5 Kb)


Сообщение отредактировал fokco - Четверг, 29.10.2020, 09:23
 
Ответить
СообщениеЕсть строка с значениями. Надо в нем найти искомое слово и скопировать его в соседнюю строку .
Пример:
Есть слово яблоко надо его столбце и скопировать его и его соседа в соседние ячейки

пробовал так
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яблоко";A1:A8));"$A2=$C2")

Код
=ПСТР(A1;ПОИСК("яблоко";A8;1)+1;99)


ВРОДЕ нашел
Код
=ЕСЛИ(A2="яблоко";A2;"")

Код
=ЕСЛИ(A2="яблоко";B2;"")

Как их объединить ?

Автор - fokco
Дата добавления - 29.10.2020 в 08:39
китин Дата: Четверг, 29.10.2020, 08:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6417
Репутация: 984 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
fokco, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеfokco, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 29.10.2020 в 08:48
Nic70y Дата: Четверг, 29.10.2020, 09:23 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
не понятно...
сделайте пример-файл без формул,
заполните вручную желаемый результат.


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениене понятно...
сделайте пример-файл без формул,
заполните вручную желаемый результат.

Автор - Nic70y
Дата добавления - 29.10.2020 в 09:23
fokco Дата: Четверг, 29.10.2020, 09:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y,
К сообщению приложен файл: 4151781.xlsx(10.8 Kb)
 
Ответить
СообщениеNic70y,

Автор - fokco
Дата добавления - 29.10.2020 в 09:39
Nic70y Дата: Четверг, 29.10.2020, 09:52 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
удалил столбец C (пустой) чтоб структура была одинаковая
Код
=ЕСЛИОШИБКА(ИНДЕКС(A2:A21;ПОИСКПОЗ("Смирнов";ИНДЕКС($A$2:B21;;СТОЛБЕЦ()-ОСТАТ(СТОЛБЕЦ()-1;2));));"")
К сообщению приложен файл: 47.xlsx(11.3 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеудалил столбец C (пустой) чтоб структура была одинаковая
Код
=ЕСЛИОШИБКА(ИНДЕКС(A2:A21;ПОИСКПОЗ("Смирнов";ИНДЕКС($A$2:B21;;СТОЛБЕЦ()-ОСТАТ(СТОЛБЕЦ()-1;2));));"")

Автор - Nic70y
Дата добавления - 29.10.2020 в 09:52
fokco Дата: Четверг, 29.10.2020, 09:54 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, Спасибо большое, Ексель могущая штука)
 
Ответить
СообщениеNic70y, Спасибо большое, Ексель могущая штука)

Автор - fokco
Дата добавления - 29.10.2020 в 09:54
fokco Дата: Четверг, 29.10.2020, 11:10 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, возник еще один вопрос возможно ли реализовать подобное как в этом примере ?
К сообщению приложен файл: 1972593.xlsx(16.4 Kb)
 
Ответить
СообщениеNic70y, возник еще один вопрос возможно ли реализовать подобное как в этом примере ?

Автор - fokco
Дата добавления - 29.10.2020 в 11:10
Nic70y Дата: Четверг, 29.10.2020, 11:24 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
если правильно понял
Код
=СУММЕСЛИ(A$23:A$34;$A38;B$23:B$34)
К сообщению приложен файл: 4835237.xlsx(22.7 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеесли правильно понял
Код
=СУММЕСЛИ(A$23:A$34;$A38;B$23:B$34)

Автор - Nic70y
Дата добавления - 29.10.2020 в 11:24
AlexM Дата: Четверг, 29.10.2020, 21:05 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Вариант решения первого вопроса темы.
Ошибка спрятана с помощью УФ
К сообщению приложен файл: 4151781_01.xlsx(14.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВариант решения первого вопроса темы.
Ошибка спрятана с помощью УФ

Автор - AlexM
Дата добавления - 29.10.2020 в 21:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке "слово" и скопировать его и соседнюю строку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!