Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск актуальной цены во 2-м файле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск актуальной цены во 2-м файле (Формулы/Formulas)
Поиск актуальной цены во 2-м файле
kolyadkl4034 Дата: Вторник, 15.03.2022, 20:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Не понимаю как это сделать формулой, может быть тут нужен макрос, в которых я 0.

Суть желаемого... выгрузил файл со своей базой, где есть Штрих-код. Так же есть файл с прайсом поставщика, где тоже есть штрих-коды и актуальная цена.
Хочу сделать так, чтобы формула(макрос) брал у товара штрихкод, искал его совпадение в файле поставщика и при нахождении вставлял в мой файл цену.

Кажется простым, но не могу понять, как это сделать.
К сообщению приложен файл: 7785920.xlsx(17.7 Kb) · 1873101.xlsx(460.9 Kb)
 
Ответить
СообщениеНе понимаю как это сделать формулой, может быть тут нужен макрос, в которых я 0.

Суть желаемого... выгрузил файл со своей базой, где есть Штрих-код. Так же есть файл с прайсом поставщика, где тоже есть штрих-коды и актуальная цена.
Хочу сделать так, чтобы формула(макрос) брал у товара штрихкод, искал его совпадение в файле поставщика и при нахождении вставлял в мой файл цену.

Кажется простым, но не могу понять, как это сделать.

Автор - kolyadkl4034
Дата добавления - 15.03.2022 в 20:22
bigorq Дата: Вторник, 15.03.2022, 20:55 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 24 ±
Замечаний: 0% ±

Нет
И вам здравствуйте.
Если прайс скопировать на лист2 Вашего файла, то формула такая
Код
=VLOOKUP(A2;Лист2.$C$34:$G$2188;5;0)
, если хотите в разных файлах, то вместо Лист2 нужен полный путь к файлу
 
Ответить
СообщениеИ вам здравствуйте.
Если прайс скопировать на лист2 Вашего файла, то формула такая
Код
=VLOOKUP(A2;Лист2.$C$34:$G$2188;5;0)
, если хотите в разных файлах, то вместо Лист2 нужен полный путь к файлу

Автор - bigorq
Дата добавления - 15.03.2022 в 20:55
kolyadkl4034 Дата: Вторник, 15.03.2022, 21:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Если прайс скопировать на лист2 Вашего файла, то формула такая

Эту формулу знаю, но у меня выдает или "ССЫЛКА" или "Н/Д". Причем не важно, копирую я на лист2 или прописываю путь. Не могу понять почему

разобрался... надо преобразовать все штрих-коды.

Не подскажете еще как сделать так, чтобы при отсутствии совпадений он ставил не Н/Д, а оставлял пустую яйчейку


Сообщение отредактировал kolyadkl4034 - Вторник, 15.03.2022, 21:31
 
Ответить
Сообщение
Если прайс скопировать на лист2 Вашего файла, то формула такая

Эту формулу знаю, но у меня выдает или "ССЫЛКА" или "Н/Д". Причем не важно, копирую я на лист2 или прописываю путь. Не могу понять почему

разобрался... надо преобразовать все штрих-коды.

Не подскажете еще как сделать так, чтобы при отсутствии совпадений он ставил не Н/Д, а оставлял пустую яйчейку

Автор - kolyadkl4034
Дата добавления - 15.03.2022 в 21:20
bigorq Дата: Вторник, 15.03.2022, 21:33 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 24 ±
Замечаний: 0% ±

Нет
у меня выдает или "ССЫЛКА" или "Н/Д"
смотрите в файле
Цитата
ставил не Н/Д, а оставлял пустую яйчейку
оберните формулу в =ЕСЛИОШИБКА(формула;"")
К сообщению приложен файл: 7785920_1.xlsx(193.5 Kb)


Сообщение отредактировал bigorq - Вторник, 15.03.2022, 21:35
 
Ответить
Сообщение
у меня выдает или "ССЫЛКА" или "Н/Д"
смотрите в файле
Цитата
ставил не Н/Д, а оставлял пустую яйчейку
оберните формулу в =ЕСЛИОШИБКА(формула;"")

Автор - bigorq
Дата добавления - 15.03.2022 в 21:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск актуальной цены во 2-м файле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!