Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/min/max по критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » min/max по критерию (Формулы/Formulas)
min/max по критерию
y811bx Дата: Вторник, 09.05.2017, 18:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! помогите плиз оптимизировать работу...
Есть таблица (столбец А,В,С) в столбцах А, В данные, в столбце С группы коэффициентов(1 или 2).
Нужно к каждой группе коэффициентов с помощью формулы поставить в столбец D максимальное значение из столбца А, а в столбец Е минимальное из столбца В. Пример прилагается Спасибо!
К сообщению приложен файл: 8587758.xlsx(11Kb)


Сообщение отредактировал y811bx - Вторник, 09.05.2017, 18:55
 
Ответить
СообщениеДобрый день! помогите плиз оптимизировать работу...
Есть таблица (столбец А,В,С) в столбцах А, В данные, в столбце С группы коэффициентов(1 или 2).
Нужно к каждой группе коэффициентов с помощью формулы поставить в столбец D максимальное значение из столбца А, а в столбец Е минимальное из столбца В. Пример прилагается Спасибо!

Автор - y811bx
Дата добавления - 09.05.2017 в 18:54
AlexM Дата: Вторник, 09.05.2017, 19:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3528
Репутация: 892 ±
Замечаний: 0% ±

Пример не понятен.
1. почему всего 4 значения показаны и не подряд.
2. максимальные и минимальные значения столбцов другие.
Может быть максимальное и минимальное не всего столбца, а из двух ячеек в строке?


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПример не понятен.
1. почему всего 4 значения показаны и не подряд.
2. максимальные и минимальные значения столбцов другие.
Может быть максимальное и минимальное не всего столбца, а из двух ячеек в строке?

Автор - AlexM
Дата добавления - 09.05.2017 в 19:16
y811bx Дата: Вторник, 09.05.2017, 20:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM согласен пример был не удачный я его немного изменил...
К сообщению приложен файл: 12.xlsx(12Kb)


Сообщение отредактировал y811bx - Вторник, 09.05.2017, 20:15
 
Ответить
СообщениеAlexM согласен пример был не удачный я его немного изменил...

Автор - y811bx
Дата добавления - 09.05.2017 в 20:13
Nic70y Дата: Вторник, 09.05.2017, 20:18 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3989
Репутация: 845 ±
Замечаний: 0% ±

Excel 2013
что-то меня ваш второй пример не впечатлил :(
по первому:
Код
=ЕСЛИ(МАКС(ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(9E+307;D$1:D1)+ПОИСКПОЗ($C2;ИНДЕКС($C:$C;ПОИСКПОЗ(9E+307;D$1:D1)):$C2;)-1;1)):ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(3-$C2;$C2:$C$128;)+СТРОКА()-2;ПОИСКПОЗ(9E+307;A:A))))=A2;A2;"")
первоначально была ошибка на 1, исправил
К сообщению приложен файл: 2267161.xlsx(19Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 09.05.2017, 20:31
 
Ответить
Сообщениечто-то меня ваш второй пример не впечатлил :(
по первому:
Код
=ЕСЛИ(МАКС(ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(9E+307;D$1:D1)+ПОИСКПОЗ($C2;ИНДЕКС($C:$C;ПОИСКПОЗ(9E+307;D$1:D1)):$C2;)-1;1)):ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(3-$C2;$C2:$C$128;)+СТРОКА()-2;ПОИСКПОЗ(9E+307;A:A))))=A2;A2;"")
первоначально была ошибка на 1, исправил

Автор - Nic70y
Дата добавления - 09.05.2017 в 20:18
AlexM Дата: Вторник, 09.05.2017, 20:30 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3528
Репутация: 892 ±
Замечаний: 0% ±

Формула массива для МАКС и МИН
Код
=ЕСЛИ(C2<>C1;МАКС(СМЕЩ(A2;;;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));D1)
Код
=ЕСЛИ(C2<>C1;МИН(СМЕЩ(B2;;;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));E1)
К сообщению приложен файл: 12_01.xlsx(19Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива для МАКС и МИН
Код
=ЕСЛИ(C2<>C1;МАКС(СМЕЩ(A2;;;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));D1)
Код
=ЕСЛИ(C2<>C1;МИН(СМЕЩ(B2;;;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));E1)

Автор - AlexM
Дата добавления - 09.05.2017 в 20:30
y811bx Дата: Вторник, 09.05.2017, 20:34 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y Спасибо то что нужно hands !!!
Сам бы я такую формулу незачто бы не придумал!!!!
 
Ответить
СообщениеNic70y Спасибо то что нужно hands !!!
Сам бы я такую формулу незачто бы не придумал!!!!

Автор - y811bx
Дата добавления - 09.05.2017 в 20:34
y811bx Дата: Вторник, 09.05.2017, 20:36 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM Спасибо hands !!!
Вариант Nic70y подошел больше...
 
Ответить
СообщениеAlexM Спасибо hands !!!
Вариант Nic70y подошел больше...

Автор - y811bx
Дата добавления - 09.05.2017 в 20:36
AlexM Дата: Вторник, 09.05.2017, 20:44 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3528
Репутация: 892 ±
Замечаний: 0% ±

Без летучей функции
Код
=ЕСЛИ(C2<>C1;МАКС(A2:ИНДЕКС(A2:A$129;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));G1)
Код
=ЕСЛИ(C2<>C1;МИН(B2:ИНДЕКС(B2:B$129;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));H1)
К сообщению приложен файл: 12_02.xlsx(27Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеБез летучей функции
Код
=ЕСЛИ(C2<>C1;МАКС(A2:ИНДЕКС(A2:A$129;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));G1)
Код
=ЕСЛИ(C2<>C1;МИН(B2:ИНДЕКС(B2:B$129;ПОИСКПОЗ(1;Ч(C2:C$128<>C3:C$129);)));H1)

Автор - AlexM
Дата добавления - 09.05.2017 в 20:44
Nic70y Дата: Вторник, 09.05.2017, 21:22 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3989
Репутация: 845 ±
Замечаний: 0% ±

Excel 2013
по 2-му немассивная
Код
=ЕСЛИ($C2=$C1;D1;МАКС(A2:ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(3-$C2;$C2:$C$128;)+СТРОКА()-2;128))))
К сообщению приложен файл: 2823400.xlsx(18Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепо 2-му немассивная
Код
=ЕСЛИ($C2=$C1;D1;МАКС(A2:ИНДЕКС(A:A;ЕСЛИОШИБКА(ПОИСКПОЗ(3-$C2;$C2:$C$128;)+СТРОКА()-2;128))))

Автор - Nic70y
Дата добавления - 09.05.2017 в 21:22
_Boroda_ Дата: Вторник, 09.05.2017, 21:54 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 10439
Репутация: 4382 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немассивка по второму варианту
Код
=ЕСЛИ(C2=C3;D3;МАКС(A2:ИНДЕКС(A:A;ПРОСМОТР(;-1/(C$1:C1<>C2);СТРОКА(A$2:A2)))))

так лучше
Код
=ЕСЛИ(C2=C3;D3;МАКС(A2:ИНДЕКС(A:A;ПРОСМОТР(2;1/(C$1:C1-C2);СТРОКА(A$2:A2)))))

Массивка по первому
Код
=ЕСЛИ(МАКС(ИНДЕКС(A:A;ПРОСМОТР(;-1/(C$1:C1<>C2);СТРОКА(A$2:A2))):ИНДЕКС(A2:A$999;ПОИСКПОЗ(0=0;C2<>C2:C$999;)-1))=A2;A2;"")
К сообщению приложен файл: 2267161_3.xlsx(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемассивка по второму варианту
Код
=ЕСЛИ(C2=C3;D3;МАКС(A2:ИНДЕКС(A:A;ПРОСМОТР(;-1/(C$1:C1<>C2);СТРОКА(A$2:A2)))))

так лучше
Код
=ЕСЛИ(C2=C3;D3;МАКС(A2:ИНДЕКС(A:A;ПРОСМОТР(2;1/(C$1:C1-C2);СТРОКА(A$2:A2)))))

Массивка по первому
Код
=ЕСЛИ(МАКС(ИНДЕКС(A:A;ПРОСМОТР(;-1/(C$1:C1<>C2);СТРОКА(A$2:A2))):ИНДЕКС(A2:A$999;ПОИСКПОЗ(0=0;C2<>C2:C$999;)-1))=A2;A2;"")

Автор - _Boroda_
Дата добавления - 09.05.2017 в 21:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » min/max по критерию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!