Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В таблице период месяцев указанных в ячейках ДАТой и ТЕКСТом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В таблице период месяцев указанных в ячейках ДАТой и ТЕКСТом (Формулы/Formulas)
В таблице период месяцев указанных в ячейках ДАТой и ТЕКСТом
Никанор Дата: Вторник, 26.06.2018, 11:30 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые помогающие!
Есть таблица в прилагаемом файле _________.xlsx(34.2 Kb).
В ячейке D9 – начало периода. В ячейке F9 – конец периода.
На листе 1 СПРОСИТЬ в двух ячейках пер
Нужно заполнить диапазон ячеек A23:A34 названиями месяцев с УСЛОВИЯМИ:
1 Условие: в ячейке А23 первый месяц, указанный в ячейке D9 – это начало периода.
А последний месяц в диапазоне A23:A34 месяц, указанный в ячейке F9 – это конец периода.
В таблице диапазоне ячеек 12 (двенадцать) ячеек, то есть максимальное число месяцев может быть 12. Если период, указанный в ячейке D9 (начало периода) и F9 (конец периода) меньше 12 месяцев то остальные ячейки диапазона A23:A34 должны быть ПУСТЫМИ.
2 Условие: 1 вариант формулы для диапазона ячеек A23:A34 заполнить формат месяца «Дата».

2 вариант формул для диапазона ячеек A23:A34 ТЕКСТ(ДАТАМЕС) – что бы название месяца было написано ТЕКСТом на русском и на украинском языке.
На украинском языке я попробую написать самостоятельно.

Возможно ли на Листе 2. СПРОС. ТЕКСТОМ в одной ячейке написать такие же формулы, только период начала и конца указан в одной ячейке D9.
С уважением.
К сообщению приложен файл: _________.xlsx(34.2 Kb)


Сообщение отредактировал Никанор - Вторник, 26.06.2018, 11:31
 
Ответить
СообщениеЗдравствуйте уважаемые помогающие!
Есть таблица в прилагаемом файле _________.xlsx(34.2 Kb).
В ячейке D9 – начало периода. В ячейке F9 – конец периода.
На листе 1 СПРОСИТЬ в двух ячейках пер
Нужно заполнить диапазон ячеек A23:A34 названиями месяцев с УСЛОВИЯМИ:
1 Условие: в ячейке А23 первый месяц, указанный в ячейке D9 – это начало периода.
А последний месяц в диапазоне A23:A34 месяц, указанный в ячейке F9 – это конец периода.
В таблице диапазоне ячеек 12 (двенадцать) ячеек, то есть максимальное число месяцев может быть 12. Если период, указанный в ячейке D9 (начало периода) и F9 (конец периода) меньше 12 месяцев то остальные ячейки диапазона A23:A34 должны быть ПУСТЫМИ.
2 Условие: 1 вариант формулы для диапазона ячеек A23:A34 заполнить формат месяца «Дата».

2 вариант формул для диапазона ячеек A23:A34 ТЕКСТ(ДАТАМЕС) – что бы название месяца было написано ТЕКСТом на русском и на украинском языке.
На украинском языке я попробую написать самостоятельно.

Возможно ли на Листе 2. СПРОС. ТЕКСТОМ в одной ячейке написать такие же формулы, только период начала и конца указан в одной ячейке D9.
С уважением.

Автор - Никанор
Дата добавления - 26.06.2018 в 11:30
_Boroda_ Дата: Вторник, 26.06.2018, 12:04 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня так получилось

Лист1
А23 просто ссылка, А24 и ниже
Код
=(КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(A23;0)+1)

Лист 2
А23
Код
=--ЛЕВБ(D9;10)
А24 и ниже
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(A23;0)+1)


Формат ячеек
[$-419]ММММ ГГГГ;;;

И текст в D9 переписал. В лист1 ввел нормальную дату, в лист2 месяц написал цифрами, а то у Вас как-то непонятно бвло - "с 01.01.2017 по 31 мая 2018 г.". Оба месяца нужно или цифрами, или буквами. Для формул-то не так страшно, просто нелогично
К сообщению приложен файл: _9.xlsx(34.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня так получилось

Лист1
А23 просто ссылка, А24 и ниже
Код
=(КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(A23;0)+1)

Лист 2
А23
Код
=--ЛЕВБ(D9;10)
А24 и ниже
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(A23;0)+1)


Формат ячеек
[$-419]ММММ ГГГГ;;;

И текст в D9 переписал. В лист1 ввел нормальную дату, в лист2 месяц написал цифрами, а то у Вас как-то непонятно бвло - "с 01.01.2017 по 31 мая 2018 г.". Оба месяца нужно или цифрами, или буквами. Для формул-то не так страшно, просто нелогично

Автор - _Boroda_
Дата добавления - 26.06.2018 в 12:04
Никанор Дата: Вторник, 26.06.2018, 12:42 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр Здравствуйте!
То что надо, чудесно!
Большое спасибо за оперативный, быстрый ответ на 34 минуте после публикации моего вопроса.
Я наверное больше времени формулировал свой вопрос чем вы ответили – написали формулы и исправили мои ошибки.
Позвольте ещё Вас спросить:
1 вопрос с моего сообщения № 1 Дата: Вторник, 26.06.2018, 11:30 там вопрос 2: Как написать формулы что бы название месяца было написано ТЕКСТом, что бы в формуле было что то наподобие ТЕКСТ(ДАТАМЕС) что бы я смог написать на украинском языке ТЕКСТом?
Полностью согласен с Вами:
Оба месяца нужно или цифрами, или буквами.

2 вопрос: как написать оба месяца буквами в Листе 2. СПРОС. ТЕКСТОМ в одной ячейке?
Я написал 01 янв 2017 г. по 31 май 2017 г. Результат в диапазоне ячеек A23:A34 #ЗНАЧ!

3. Вопрос для общего знания по Excel: что значит в формуле два «тире» или «минуса» =--ЛЕВБ?


Сообщение отредактировал Никанор - Вторник, 26.06.2018, 12:44
 
Ответить
Сообщение_Boroda_, – Александр Здравствуйте!
То что надо, чудесно!
Большое спасибо за оперативный, быстрый ответ на 34 минуте после публикации моего вопроса.
Я наверное больше времени формулировал свой вопрос чем вы ответили – написали формулы и исправили мои ошибки.
Позвольте ещё Вас спросить:
1 вопрос с моего сообщения № 1 Дата: Вторник, 26.06.2018, 11:30 там вопрос 2: Как написать формулы что бы название месяца было написано ТЕКСТом, что бы в формуле было что то наподобие ТЕКСТ(ДАТАМЕС) что бы я смог написать на украинском языке ТЕКСТом?
Полностью согласен с Вами:
Оба месяца нужно или цифрами, или буквами.

2 вопрос: как написать оба месяца буквами в Листе 2. СПРОС. ТЕКСТОМ в одной ячейке?
Я написал 01 янв 2017 г. по 31 май 2017 г. Результат в диапазоне ячеек A23:A34 #ЗНАЧ!

3. Вопрос для общего знания по Excel: что значит в формуле два «тире» или «минуса» =--ЛЕВБ?

Автор - Никанор
Дата добавления - 26.06.2018 в 12:42
_Boroda_ Дата: Вторник, 26.06.2018, 13:21 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Вы всегда можете поставить соответствующий формат - русский, украинский, китайский, ...
или написать в формуле
Код
=ТЕКСТ(формула ;"[$-FC22]ММММ ГГГ")


2.
Код
=--ЛЕВБ(D9;11)
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(A23;0)+1)


3. http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Вы всегда можете поставить соответствующий формат - русский, украинский, китайский, ...
или написать в формуле
Код
=ТЕКСТ(формула ;"[$-FC22]ММММ ГГГ")


2.
Код
=--ЛЕВБ(D9;11)
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(A23;0)+1)


3. http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9

Автор - _Boroda_
Дата добавления - 26.06.2018 в 13:21
Никанор Дата: Вторник, 26.06.2018, 15:23 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр!
Большое спасибо за ответ и формулы.
И что напомнили, объяснили, что не только в формуле можно ставить формат [$-FC22] и так далее а это же можно делать и в формате ячеек. Я это уже забыл.
Спасибо также за ссылку с ответом – объяснением на мой 3 вопрос.
У меня получилось сделать по второму вопросу – я просто ввёл Ваши формулы и протянул их вниз.

А написать ТЕКСТом не получилось.
Извините что надоедаю, но если можно подскажите, пожалуйста:
1. Как написать формулы ТЕКСТом на 1 листе.
2. Почему на листе 2 в Вашем файле формула
Код
=--ЛЕВБ(D9;10)
там формат 01.01.18. Что значит цифра 10 после точки с запятой? А ЕСЛИ формат 01 янв 2017 г. по 31 май 2017 г. формула
Код
=--ЛЕВБ(D9;11)
Почему тут уже цифра 11 после точки с запятой?

3. Можно ли в этой таблице поставить «Проверка вводимых значений»? Данные → Проверка данных «Набор значений, которые могут быть введены в ячейку, ограничен». Что бы появлялось диалоговое окно в случае, ЕСЛИ ввёл ошибочно в ячейку, F9 например период больше 12 месяцев или дату месяца больше 32, или если в месяце 30 дней – ввёл 31 число.
С уважением.
К сообщению приложен файл: ______4-9.xlsx(34.8 Kb)


Сообщение отредактировал Никанор - Вторник, 26.06.2018, 15:36
 
Ответить
Сообщение_Boroda_, – Александр!
Большое спасибо за ответ и формулы.
И что напомнили, объяснили, что не только в формуле можно ставить формат [$-FC22] и так далее а это же можно делать и в формате ячеек. Я это уже забыл.
Спасибо также за ссылку с ответом – объяснением на мой 3 вопрос.
У меня получилось сделать по второму вопросу – я просто ввёл Ваши формулы и протянул их вниз.

А написать ТЕКСТом не получилось.
Извините что надоедаю, но если можно подскажите, пожалуйста:
1. Как написать формулы ТЕКСТом на 1 листе.
2. Почему на листе 2 в Вашем файле формула
Код
=--ЛЕВБ(D9;10)
там формат 01.01.18. Что значит цифра 10 после точки с запятой? А ЕСЛИ формат 01 янв 2017 г. по 31 май 2017 г. формула
Код
=--ЛЕВБ(D9;11)
Почему тут уже цифра 11 после точки с запятой?

3. Можно ли в этой таблице поставить «Проверка вводимых значений»? Данные → Проверка данных «Набор значений, которые могут быть введены в ячейку, ограничен». Что бы появлялось диалоговое окно в случае, ЕСЛИ ввёл ошибочно в ячейку, F9 например период больше 12 месяцев или дату месяца больше 32, или если в месяце 30 дней – ввёл 31 число.
С уважением.

Автор - Никанор
Дата добавления - 26.06.2018 в 15:23
_Boroda_ Дата: Вторник, 26.06.2018, 16:11 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")
Это для Лист1. Для Лист2 сами совместите две формулы
2. А справку по функции посмотреть не? https://support.office.com/ru-ru....b99640c
3. Этот вопрос не относится к текущей теме
К сообщению приложен файл: _8.xlsx(34.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")
Это для Лист1. Для Лист2 сами совместите две формулы
2. А справку по функции посмотреть не? https://support.office.com/ru-ru....b99640c
3. Этот вопрос не относится к текущей теме

Автор - _Boroda_
Дата добавления - 26.06.2018 в 16:11
Никанор Дата: Среда, 27.06.2018, 09:30 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр!
Большое спасибо за ответ и файл.
Извините что снова Вас спрашиваю, но я пробую делать 2 лист но не получается.

Для ячейки А23 у меня получилась формула
Код
=ЛЕВБ(ТЕКСТ(D9;"ММММ ГГГ \г.");10)

Но результат не ТЕКСТ а 01.01.2017
1 вопрос: Как надо изменить формулу в ячейку А23, что бы было Январь 2017
Для ячейки А24 формула
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(A23;0)+1);"ММММ ГГГ \г.;;");"")

результат правильный ТЕКСТом Февраль 2017 г.
«Протянул» вниз – а ниже пустые ячейки.
2 вопрос: Подскажите, пожалуйста, что я сделал неправильно – как надо изменить формулу, что бы была заполнена таблица.
Файл прикладываю.
К сообщению приложен файл: -8___2__.xlsx(34.9 Kb)


Сообщение отредактировал Никанор - Среда, 27.06.2018, 09:33
 
Ответить
Сообщение_Boroda_, – Александр!
Большое спасибо за ответ и файл.
Извините что снова Вас спрашиваю, но я пробую делать 2 лист но не получается.

Для ячейки А23 у меня получилась формула
Код
=ЛЕВБ(ТЕКСТ(D9;"ММММ ГГГ \г.");10)

Но результат не ТЕКСТ а 01.01.2017
1 вопрос: Как надо изменить формулу в ячейку А23, что бы было Январь 2017
Для ячейки А24 формула
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(A23;0)+1);"ММММ ГГГ \г.;;");"")

результат правильный ТЕКСТом Февраль 2017 г.
«Протянул» вниз – а ниже пустые ячейки.
2 вопрос: Подскажите, пожалуйста, что я сделал неправильно – как надо изменить формулу, что бы была заполнена таблица.
Файл прикладываю.

Автор - Никанор
Дата добавления - 27.06.2018 в 09:30
_Boroda_ Дата: Среда, 27.06.2018, 09:49 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Наоборот. Сначала 10 левых символов, потом их переделываем в текст
Код
=ТЕКСТ(ЛЕВБ(D9;11);"ММММ ГГГ \г.")

Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")
К сообщению приложен файл: -8_2_1.xlsx(35.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНаоборот. Сначала 10 левых символов, потом их переделываем в текст
Код
=ТЕКСТ(ЛЕВБ(D9;11);"ММММ ГГГ \г.")

Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")

Автор - _Boroda_
Дата добавления - 27.06.2018 в 09:49
Никанор Дата: Среда, 27.06.2018, 16:19 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр!
Большое спасибо за ответ и прикреплённый файл с решением вопроса на 19 минуте.
И ещё если можно подскажите пожалуйста как в файле -8_2_1.xlsx(35.0 Kb) к формуле добавить украинский язык?
Я попробовал для ячейки А23 формулу
Код
=ТЕКСТ(ЛЕВБ(D9;11);"[$-422]ММММ ГГГГ")
она даёт результат правильный – Січень 2017. Это по русскому Январь 2017.
А для ячейки А24 написал формулу:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"[$-422]ММММ ГГГГ");"")

Результат – пустая ячейка. Я в формулу дописал "[$-422]ММММ ГГГГ".
Наверное что то сделал не так – не туда вставил "[$-422]ММММ ГГГГ"
Подскажите пожалуйста.


Сообщение отредактировал Никанор - Среда, 27.06.2018, 16:23
 
Ответить
Сообщение_Boroda_, – Александр!
Большое спасибо за ответ и прикреплённый файл с решением вопроса на 19 минуте.
И ещё если можно подскажите пожалуйста как в файле -8_2_1.xlsx(35.0 Kb) к формуле добавить украинский язык?
Я попробовал для ячейки А23 формулу
Код
=ТЕКСТ(ЛЕВБ(D9;11);"[$-422]ММММ ГГГГ")
она даёт результат правильный – Січень 2017. Это по русскому Январь 2017.
А для ячейки А24 написал формулу:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"[$-422]ММММ ГГГГ");"")

Результат – пустая ячейка. Я в формулу дописал "[$-422]ММММ ГГГГ".
Наверное что то сделал не так – не туда вставил "[$-422]ММММ ГГГГ"
Подскажите пожалуйста.

Автор - Никанор
Дата добавления - 27.06.2018 в 16:19
Никанор Дата: Четверг, 28.06.2018, 08:48 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Уважаемые помогающие!
Извините пожалуйста что обращаюсь повторно, но у меня самостоятельно не получается изменить формулы которые написал _Boroda_ – Александр в Сообщение № 8 Дата: Среда, 27.06.2018, 09:49 на украинский язык. Это файл -8_2_1.xlsx(35.0 Kb) в сообщении № 8.
И мой вопрос в Сообщение № 9 Дата: Среда, 27.06.2018, 16:19.
Помогите, пожалуйста изменить формулы на украинский язык.
Это изменение в формуле имеет прямое отношение к теме.
С уважением.


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 08:52
 
Ответить
СообщениеУважаемые помогающие!
Извините пожалуйста что обращаюсь повторно, но у меня самостоятельно не получается изменить формулы которые написал _Boroda_ – Александр в Сообщение № 8 Дата: Среда, 27.06.2018, 09:49 на украинский язык. Это файл -8_2_1.xlsx(35.0 Kb) в сообщении № 8.
И мой вопрос в Сообщение № 9 Дата: Среда, 27.06.2018, 16:19.
Помогите, пожалуйста изменить формулы на украинский язык.
Это изменение в формуле имеет прямое отношение к теме.
С уважением.

Автор - Никанор
Дата добавления - 28.06.2018 в 08:48
_Boroda_ Дата: Четверг, 28.06.2018, 09:15 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")
К сообщению приложен файл: -8_2_2.xlsx(34.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1<=F$9)*(КОНМЕСЯЦА(D$9;СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

Автор - _Boroda_
Дата добавления - 28.06.2018 в 09:15
Никанор Дата: Четверг, 28.06.2018, 10:01 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр Здравствуйте!
Спасибо большое что быстро ответили.
Да! Так нужно совершенно верно. Так как в файле
-8_2_2.xlsx(34.9 Kb). на листе 1 и на листе 2 ТЕКСТ на украинском языке.
Только я не пойму, в сообщении № 11 Дата: Четверг, 28.06.2018, 09:15 первая формула я так понял для ячейки А23 одна,а в файле для ячейки А23 совсем другая формула, вот такая:
Код
=ТЕКСТ(ЛЕВБ(D$9;10);"[$-422]ММММ ГГГ р.")

И если вставить в ячейку формулу из сообщения – то результат для ячейки А23 – неправильный – пустая ячейка. В первой формуле из Вашего сообщении № 11 Дата: Четверг, 28.06.2018, 09:15 задейстована ячейка F$9. А в файле эта ячейка пустая. Наверное из-за этого если вставит её в файл результат ПУСТО.
Но главное результат в файле правильный! Так как надо.

Ещё 2 вопроса если позволите: написать две формулы на русском и украинском языке с УСЛОВИЕМ:
ЕСЛИ на Листе 2 в ячейку D9 написать 01 янв 2017 г. по 31 май 2017 г.
(сейчас в ячейке D9 написано: 01.01.2017 г. по 31.05.2017 г.) и что бы в таблице в диапазоне ячеек был А23:А34 результат был:
1 вариант формулы месяц ТЕКСТом на русском языке
2 вариант формулы месяц ТЕКСТом на украинском языке
С уважением.


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 10:05
 
Ответить
Сообщение_Boroda_, – Александр Здравствуйте!
Спасибо большое что быстро ответили.
Да! Так нужно совершенно верно. Так как в файле
-8_2_2.xlsx(34.9 Kb). на листе 1 и на листе 2 ТЕКСТ на украинском языке.
Только я не пойму, в сообщении № 11 Дата: Четверг, 28.06.2018, 09:15 первая формула я так понял для ячейки А23 одна,а в файле для ячейки А23 совсем другая формула, вот такая:
Код
=ТЕКСТ(ЛЕВБ(D$9;10);"[$-422]ММММ ГГГ р.")

И если вставить в ячейку формулу из сообщения – то результат для ячейки А23 – неправильный – пустая ячейка. В первой формуле из Вашего сообщении № 11 Дата: Четверг, 28.06.2018, 09:15 задейстована ячейка F$9. А в файле эта ячейка пустая. Наверное из-за этого если вставит её в файл результат ПУСТО.
Но главное результат в файле правильный! Так как надо.

Ещё 2 вопроса если позволите: написать две формулы на русском и украинском языке с УСЛОВИЕМ:
ЕСЛИ на Листе 2 в ячейку D9 написать 01 янв 2017 г. по 31 май 2017 г.
(сейчас в ячейке D9 написано: 01.01.2017 г. по 31.05.2017 г.) и что бы в таблице в диапазоне ячеек был А23:А34 результат был:
1 вариант формулы месяц ТЕКСТом на русском языке
2 вариант формулы месяц ТЕКСТом на украинском языке
С уважением.

Автор - Никанор
Дата добавления - 28.06.2018 в 10:01
Никанор Дата: Четверг, 28.06.2018, 10:55 | Сообщение № 13
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Уважаемые помогающие!
Помогите пожалуйста ответить на вопросы в последнем абзаце из моего прошлого Сообщение № 12 Дата: Четверг, 28.06.2018, 10:01.
Я пробую написать формулы, но у меня ничего не получается.
Прикладываю файл. Там пример на Лист2СПРОС. ТЕКСТОМ в одной ячейке.
С уважением.
К сообщению приложен файл: _4-9.xlsx(34.8 Kb)


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 10:58
 
Ответить
СообщениеУважаемые помогающие!
Помогите пожалуйста ответить на вопросы в последнем абзаце из моего прошлого Сообщение № 12 Дата: Четверг, 28.06.2018, 10:01.
Я пробую написать формулы, но у меня ничего не получается.
Прикладываю файл. Там пример на Лист2СПРОС. ТЕКСТОМ в одной ячейке.
С уважением.

Автор - Никанор
Дата добавления - 28.06.2018 в 10:55
Никанор Дата: Четверг, 28.06.2018, 11:53 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
У меня самостоятельно получилось написать только одну формулу как я спрашивал в сообщениях № 12 и № 13 для ячейки А23
с УСЛОВИЕМ если в ячейке D9 написано 01 янв 2017 г. по 31 май 2017 г.
вот формула для русского языка:
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-419]ММММ ГГГ р.")
Формат ячейки – Общий
а вот для украинского языка
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-422]ММММ ГГГ р.")
Формат ячейки – Общий
Уважаемые помогающие!
У меня никак не получается изменить – написать формулу для диапазона ячеек А24:А34.
Помогите пожалуйста изменить формулу
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(A23;0)+1)
для диапазона ячеек А23:А34 для русского и украинского языка что бы в ячейках было название месяцев ТЕКСТом.
То есть что бы в формуле присутствовала функция ТЕКСТ.

С уважением.


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 12:01
 
Ответить
СообщениеУ меня самостоятельно получилось написать только одну формулу как я спрашивал в сообщениях № 12 и № 13 для ячейки А23
с УСЛОВИЕМ если в ячейке D9 написано 01 янв 2017 г. по 31 май 2017 г.
вот формула для русского языка:
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-419]ММММ ГГГ р.")
Формат ячейки – Общий
а вот для украинского языка
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-422]ММММ ГГГ р.")
Формат ячейки – Общий
Уважаемые помогающие!
У меня никак не получается изменить – написать формулу для диапазона ячеек А24:А34.
Помогите пожалуйста изменить формулу
Код
=(КОНМЕСЯЦА(A$23;СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(A23;0)+1)
для диапазона ячеек А23:А34 для русского и украинского языка что бы в ячейках было название месяцев ТЕКСТом.
То есть что бы в формуле присутствовала функция ТЕКСТ.

С уважением.

Автор - Никанор
Дата добавления - 28.06.2018 в 11:53
Никанор Дата: Четверг, 28.06.2018, 12:20 | Сообщение № 15
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста, как написать формулу условия в моих сообщениях № 12, № 13 № 14.
С уважением.


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 12:30
 
Ответить
СообщениеПодскажите пожалуйста, как написать формулу условия в моих сообщениях № 12, № 13 № 14.
С уважением.

Автор - Никанор
Дата добавления - 28.06.2018 в 12:20
_Boroda_ Дата: Четверг, 28.06.2018, 13:14 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Цитата Никанор, 28.06.2018 в 10:01, в сообщении № 12 ()
Только я не пойму
Ну блин! Это формулы для разных листов

Я заколебался уже - Вы задаете одни и те же вопросы по кругу. У Вас есть все варианты формул. Все. И для двух дат, и для двух текстовых дат, и для двух дат в одной ячейке, и для двух текстовых дат в одной ячейке. Все это для записи периодов в А23:А34 датами и для записи текстом. Выпишите все эти формулы где-нибудь отдельно, напишите рядом коротенькие комментарии (для каких условий эта формула), проанализируйте и попробуйте что-то написать самостоятельно

Или просто составьте отдельный файл со всеми вариантами записей и всеми вариантами типов данных в итоге. Заполните формулами те варианты, что у Вас уже есть и своими попытками те, которых еще нет. И положите сюда


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Цитата Никанор, 28.06.2018 в 10:01, в сообщении № 12 ()
Только я не пойму
Ну блин! Это формулы для разных листов

Я заколебался уже - Вы задаете одни и те же вопросы по кругу. У Вас есть все варианты формул. Все. И для двух дат, и для двух текстовых дат, и для двух дат в одной ячейке, и для двух текстовых дат в одной ячейке. Все это для записи периодов в А23:А34 датами и для записи текстом. Выпишите все эти формулы где-нибудь отдельно, напишите рядом коротенькие комментарии (для каких условий эта формула), проанализируйте и попробуйте что-то написать самостоятельно

Или просто составьте отдельный файл со всеми вариантами записей и всеми вариантами типов данных в итоге. Заполните формулами те варианты, что у Вас уже есть и своими попытками те, которых еще нет. И положите сюда

Автор - _Boroda_
Дата добавления - 28.06.2018 в 13:14
Никанор Дата: Четверг, 28.06.2018, 14:31 | Сообщение № 17
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
У меня нет только варианта для ТЕКСТОВЫХ дат в одной ячейке D9 и что бы ТЕКСТом было в таблице:
ЕСЛИ в В ячейке D9 ТЕКСТ 01 янв 2017 г. по 31 май 2017 г.
Что бы в диапазоне ячеек A23:A34 написать ТЕКСТОМ на русском и на украинском языке.

В ячейке D9 ТЕКСТ 01 янв 2017 г. по 31 май 2017 г.
Мне нужно: написать ТЕКСТ в диапазон ячеек A23:A34.
Лист 1 на русском языке: В ячейку А23 у меня получилось ТЕКСТом написать формулу
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-419]ММММ ГГГ р.")

Или без [$-419]
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"ММММ ГГГ р.")

В ячейку А24 я пробую писать формулу на примере Вашей формулы, когда в D9 написано: 01.01.2017 г. по 31.05.2017 г.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")

У меня получилась формула:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;11))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")

Но она неправильная.

На листе 2 на украинском языке В ячейку А23 у меня получилось ТЕКСТом написать формулу
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-422]ММММ ГГГ р.")

В ячейку А24 я пробую писать формулу на примере Вашей формулы, когда в D9 написано: 01.01.2017 г. по 31.05.2017 г.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

У меня получилась формула:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

Я 10 заменил на 11 но результат неправильный ПУСТО.
Пробовал и другие варианты написания формул, но тоже было неправильно.
Прикрепляю файл.
К сообщению приложен файл: __D9___A23_A34_.xlsx(34.6 Kb)


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 14:39
 
Ответить
СообщениеУ меня нет только варианта для ТЕКСТОВЫХ дат в одной ячейке D9 и что бы ТЕКСТом было в таблице:
ЕСЛИ в В ячейке D9 ТЕКСТ 01 янв 2017 г. по 31 май 2017 г.
Что бы в диапазоне ячеек A23:A34 написать ТЕКСТОМ на русском и на украинском языке.

В ячейке D9 ТЕКСТ 01 янв 2017 г. по 31 май 2017 г.
Мне нужно: написать ТЕКСТ в диапазон ячеек A23:A34.
Лист 1 на русском языке: В ячейку А23 у меня получилось ТЕКСТом написать формулу
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-419]ММММ ГГГ р.")

Или без [$-419]
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"ММММ ГГГ р.")

В ячейку А24 я пробую писать формулу на примере Вашей формулы, когда в D9 написано: 01.01.2017 г. по 31.05.2017 г.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")

У меня получилась формула:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;11))*(КОНМЕСЯЦА(ПОДСТАВИТЬ(A23;" г.";);0)+1);"ММММ ГГГ \г.;;");"")

Но она неправильная.

На листе 2 на украинском языке В ячейку А23 у меня получилось ТЕКСТом написать формулу
Код
=ТЕКСТ(ЛЕВБ(D$9;11);"[$-422]ММММ ГГГ р.")

В ячейку А24 я пробую писать формулу на примере Вашей формулы, когда в D9 написано: 01.01.2017 г. по 31.05.2017 г.
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;10))*(КОНМЕСЯЦА(ЛЕВБ(D$9;10);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

У меня получилась формула:
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;18;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

Я 10 заменил на 11 но результат неправильный ПУСТО.
Пробовал и другие варианты написания формул, но тоже было неправильно.
Прикрепляю файл.

Автор - Никанор
Дата добавления - 28.06.2018 в 14:31
_Boroda_ Дата: Четверг, 28.06.2018, 14:49 | Сообщение № 18
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
укр файл 1
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

рус файл 2
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-419]ММММ ГГГ \г.;;");"")

мажно короче, специально сделал по шаблону
К сообщению приложен файл: _D9_A23_A34_1.xlsx(34.8 Kb) · _D9_A23_A34_2.xlsx(34.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеукр файл 1
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-422]ММММ ГГГ р.;;");"")

рус файл 2
Код
=ЕСЛИОШИБКА(ТЕКСТ((КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1<=--ПСТР(D$9;19;11))*(КОНМЕСЯЦА(ЛЕВБ(D$9;11);СТРОКА(A1)-1)+1);"[$-419]ММММ ГГГ \г.;;");"")

мажно короче, специально сделал по шаблону

Автор - _Boroda_
Дата добавления - 28.06.2018 в 14:49
Никанор Дата: Четверг, 28.06.2018, 15:10 | Сообщение № 19
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, – Александр!
Всё отлично, так как я и хотел!
Извините, пожалуйста, что может Вам надоедал с вопросами.
Очень большое спасибо за терпение и ответ.

Да я не правильно писал формулы. Увидел что в Вашей формуле ЛЕВБ написано в двух частях формулы. Я бы так не написал.
мажно короче

Интересно было бы посмотреть на короткую формулу – но уже не буду Вам надоедать и отвлекать.

Уже не вопрос, а просто для информации просто интересно. Я скачал Ваш файл на украинском языке и открыл названия месяцев были с маленькой буквы. А когда в ячейке курсором зашёл в Строку формул и нажал на клавишу Enter, название месяца изменилось и стало с большой буквы. Название изменялось только в том случае, если я в ячейке в строке формул я ставил курсор и нажимал клавишу Enter.
А в файле на русском языке названия месяцев были с большой буквы.
С уважением и большой благодарностью.


Сообщение отредактировал Никанор - Четверг, 28.06.2018, 15:13
 
Ответить
Сообщение_Boroda_, – Александр!
Всё отлично, так как я и хотел!
Извините, пожалуйста, что может Вам надоедал с вопросами.
Очень большое спасибо за терпение и ответ.

Да я не правильно писал формулы. Увидел что в Вашей формуле ЛЕВБ написано в двух частях формулы. Я бы так не написал.
мажно короче

Интересно было бы посмотреть на короткую формулу – но уже не буду Вам надоедать и отвлекать.

Уже не вопрос, а просто для информации просто интересно. Я скачал Ваш файл на украинском языке и открыл названия месяцев были с маленькой буквы. А когда в ячейке курсором зашёл в Строку формул и нажал на клавишу Enter, название месяца изменилось и стало с большой буквы. Название изменялось только в том случае, если я в ячейке в строке формул я ставил курсор и нажимал клавишу Enter.
А в файле на русском языке названия месяцев были с большой буквы.
С уважением и большой благодарностью.

Автор - Никанор
Дата добавления - 28.06.2018 в 15:10
Никанор Дата: Понедельник, 02.07.2018, 14:39 | Сообщение № 20
Группа: Проверенные
Ранг: Обитатель
Сообщений: 346
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемый _Boroda_, – Александр!
Хочу ещё раз поблагодарить Вас за раз за ответы на все мои «надоедливые» вопросы и написание разных формул с разными условиями.
Выпишите все эти формулы где-нибудь отдельно, напишите рядом коротенькие комментарии (для каких условий эта формула)

Вы написали аж 8 (восемь), вариантов разных формул, которые я систематизировал:
1. В двух разных ячейках ДАТА в формате 01.01.2017 и 31.05.2017 г. = в таблице результат ДАТА не текстом на русском языке.
2. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА не текстом на русском языке.
3. В двух разных ячейках ДАТА в формате 01.01.2018 и 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.
4. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.
5. ДАТА в двух разных ячейках в формате 01.01.2018 и 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
6. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
7. ДАТА в одной ячейке в формате 01 янв 2017 г. по 31 май 2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
8. ДАТА в одной ячейке в формате 01 янв 2017 г. по 31 май 2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.

Ещё раз повторно благодарю Вас за все ответы на мои вопросы.
С уважением и наилучшими пожеланиями.


Сообщение отредактировал Никанор - Понедельник, 02.07.2018, 14:45
 
Ответить
СообщениеЗдравствуйте уважаемый _Boroda_, – Александр!
Хочу ещё раз поблагодарить Вас за раз за ответы на все мои «надоедливые» вопросы и написание разных формул с разными условиями.
Выпишите все эти формулы где-нибудь отдельно, напишите рядом коротенькие комментарии (для каких условий эта формула)

Вы написали аж 8 (восемь), вариантов разных формул, которые я систематизировал:
1. В двух разных ячейках ДАТА в формате 01.01.2017 и 31.05.2017 г. = в таблице результат ДАТА не текстом на русском языке.
2. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА не текстом на русском языке.
3. В двух разных ячейках ДАТА в формате 01.01.2018 и 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.
4. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.
5. ДАТА в двух разных ячейках в формате 01.01.2018 и 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
6. ДАТА в одной ячейке в формате 01.01.2017 г. по 31.05.2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
7. ДАТА в одной ячейке в формате 01 янв 2017 г. по 31 май 2017 г. = в таблице результат ДАТА ТЕКСТом на украинском языке.
8. ДАТА в одной ячейке в формате 01 янв 2017 г. по 31 май 2017 г. = в таблице результат ДАТА ТЕКСТом на русском языке.

Ещё раз повторно благодарю Вас за все ответы на мои вопросы.
С уважением и наилучшими пожеланиями.

Автор - Никанор
Дата добавления - 02.07.2018 в 14:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В таблице период месяцев указанных в ячейках ДАТой и ТЕКСТом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!