Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт цены исходя из суммы заказа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт цены исходя из суммы заказа (Формулы/Formulas)
Расчёт цены исходя из суммы заказа
FERZb Дата: Понедельник, 09.10.2017, 20:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Подскажите пожалуйста, как правильно сделать расчёт цены исходя из объёма заказа в рублях.
Т.е. при заказе до 20к руб цена такая то свыше 20 к руб такая то свыше 100к руб такая то.
Пример таблицы во влоежении.
К сообщению приложен файл: 4893695.xlsx(9Kb)
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста, как правильно сделать расчёт цены исходя из объёма заказа в рублях.
Т.е. при заказе до 20к руб цена такая то свыше 20 к руб такая то свыше 100к руб такая то.
Пример таблицы во влоежении.

Автор - FERZb
Дата добавления - 09.10.2017 в 20:45
_Igor_61 Дата: Понедельник, 09.10.2017, 20:56 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте! А пример точно тот? Вы просите определить цену в зависимости от величины заказа, а в примере наоборот -цены уже есть, а сумма заказа неизвестна
 
Ответить
СообщениеЗдравствуйте! А пример точно тот? Вы просите определить цену в зависимости от величины заказа, а в примере наоборот -цены уже есть, а сумма заказа неизвестна

Автор - _Igor_61
Дата добавления - 09.10.2017 в 20:56
FERZb Дата: Понедельник, 09.10.2017, 21:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! А пример точно тот? Вы просите определить цену в зависимости от величины заказа, а в примере наоборот -цены уже есть, а сумма заказа неизвестна

Прошу прощения, так и есть!!!

Если обобщить то хочется чтобы автоматически подставлялась нужная цена исходя из суммы заказа.
Т.е. заказал я на 21к расчёт произвелся по 1категории цен
 
Ответить
Сообщение
Здравствуйте! А пример точно тот? Вы просите определить цену в зависимости от величины заказа, а в примере наоборот -цены уже есть, а сумма заказа неизвестна

Прошу прощения, так и есть!!!

Если обобщить то хочется чтобы автоматически подставлялась нужная цена исходя из суммы заказа.
Т.е. заказал я на 21к расчёт произвелся по 1категории цен

Автор - FERZb
Дата добавления - 09.10.2017 в 21:00
_Igor_61 Дата: Понедельник, 09.10.2017, 21:38 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
Для начала в Вашем файле нужно точки на запятые заменить - F9 - найти - заменить. А уже потом
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(E2>=3000;E2<20000);A2*D2;ЕСЛИ(И(E2>=20000;E2<100000);B2*D2;C2*D2));"")
К сообщению приложен файл: 3299961.xlsx(9Kb)
 
Ответить
СообщениеДля начала в Вашем файле нужно точки на запятые заменить - F9 - найти - заменить. А уже потом
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(E2>=3000;E2<20000);A2*D2;ЕСЛИ(И(E2>=20000;E2<100000);B2*D2;C2*D2));"")

Автор - _Igor_61
Дата добавления - 09.10.2017 в 21:38
_Boroda_ Дата: Понедельник, 09.10.2017, 22:09 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я так понял, что сверять 3000-20000-100000 нужно общую сумму.
Если да, то такой вариант. Совсем неоптимизированный. Совсем-совсем
Код
=ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","))<3000;;ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","))<20000;СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","));ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(B2:B23;".";","))<100000;СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(B2:B23;".";","));СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(C2:C23;".";",")))))
К сообщению приложен файл: 4893695_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ так понял, что сверять 3000-20000-100000 нужно общую сумму.
Если да, то такой вариант. Совсем неоптимизированный. Совсем-совсем
Код
=ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","))<3000;;ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","))<20000;СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(A2:A23;".";","));ЕСЛИ(СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(B2:B23;".";","))<100000;СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(B2:B23;".";","));СУММПРОИЗВ($D2:$D23*ПОДСТАВИТЬ(C2:C23;".";",")))))

Автор - _Boroda_
Дата добавления - 09.10.2017 в 22:09
vikttur Дата: Вторник, 10.10.2017, 01:29 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2559
Репутация: 460 ±
Замечаний: 0% ±

Перед применением формул текст преобразовать в нормальную стоимость:
выделить столбцы A:C, Ctrl+H, Найти точку, заменить на запятую.

Для упрощения вычислений нужно иметь три суммы для разных диапазонов:
Код
=СУММПРОИЗВ(A2:A23;$D$2:$D$23)

И выбирать из них:
Код
=ЕСЛИ(F2<F1;;ПРОСМОТР(2;1/(F1:H1<F2:H2);F2:H2))
К сообщению приложен файл: price.xlsx(10Kb)
 
Ответить
СообщениеПеред применением формул текст преобразовать в нормальную стоимость:
выделить столбцы A:C, Ctrl+H, Найти точку, заменить на запятую.

Для упрощения вычислений нужно иметь три суммы для разных диапазонов:
Код
=СУММПРОИЗВ(A2:A23;$D$2:$D$23)

И выбирать из них:
Код
=ЕСЛИ(F2<F1;;ПРОСМОТР(2;1/(F1:H1<F2:H2);F2:H2))

Автор - vikttur
Дата добавления - 10.10.2017 в 01:29
FERZb Дата: Вторник, 10.10.2017, 06:39 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день!

Спасибо за ответы, видимо я некорректно описал задание :(
Постараюсь описать подробно все условия.

- Расчёт должен производиться ПО КАЖДОЙ ПОЗИЦИИ ПРАЙСА отдельно
- Проверка происходит не по общей сумме заказа а по сумме заказа по каждой позиции прайса
- Кол-во заказанных единиц по каждой позиции разная
- Общая сумма заказа, по всем позициям не влияет на выбор цены
- На выбор цены влияет сумма заказа по каждой позиции (если сли сумма заказа по позиции 16-к свыше 20к руб то к позиции применяем цену 1; если сумма заказа по позиции 12-к свыше 100к руб то к позиции применяем цену 2)
 
Ответить
СообщениеВсем добрый день!

Спасибо за ответы, видимо я некорректно описал задание :(
Постараюсь описать подробно все условия.

- Расчёт должен производиться ПО КАЖДОЙ ПОЗИЦИИ ПРАЙСА отдельно
- Проверка происходит не по общей сумме заказа а по сумме заказа по каждой позиции прайса
- Кол-во заказанных единиц по каждой позиции разная
- Общая сумма заказа, по всем позициям не влияет на выбор цены
- На выбор цены влияет сумма заказа по каждой позиции (если сли сумма заказа по позиции 16-к свыше 20к руб то к позиции применяем цену 1; если сумма заказа по позиции 12-к свыше 100к руб то к позиции применяем цену 2)

Автор - FERZb
Дата добавления - 10.10.2017 в 06:39
_Boroda_ Дата: Вторник, 10.10.2017, 09:08 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда все аналогично, но без СУММПРОИЗВ
Код
=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))

В файле еще покраску проверки сделал Условным форматированием
К сообщению приложен файл: 1058372.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда все аналогично, но без СУММПРОИЗВ
Код
=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))

В файле еще покраску проверки сделал Условным форматированием

Автор - _Boroda_
Дата добавления - 10.10.2017 в 09:08
FERZb Дата: Среда, 11.10.2017, 12:59 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо за ответ!
Решили использовать эту формулу.
Но у меня какая то проблема, выдаёт ошибку ЗНАЧ
Я понимаю что это из за пустых ячеек в разрыве в которых текст - я в этих ячейках поставил 1 - но формула всё равно выдаёт ЗНАЧ.

В вашем примере поставил 1 всё работает(

Проверил везде цифры и больше нет разрывов
 
Ответить
СообщениеСпасибо за ответ!
Решили использовать эту формулу.
Но у меня какая то проблема, выдаёт ошибку ЗНАЧ
Я понимаю что это из за пустых ячеек в разрыве в которых текст - я в этих ячейках поставил 1 - но формула всё равно выдаёт ЗНАЧ.

В вашем примере поставил 1 всё работает(

Проверил везде цифры и больше нет разрывов

Автор - FERZb
Дата добавления - 11.10.2017 в 12:59
_Boroda_ Дата: Среда, 11.10.2017, 13:16 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Где? Покажите в файле


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеГде? Покажите в файле

Автор - _Boroda_
Дата добавления - 11.10.2017 в 13:16
FERZb Дата: Среда, 11.10.2017, 13:37 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всё заработало! Спасибо - сегодня скину на ЯД
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
 
Ответить
СообщениеВсё заработало! Спасибо - сегодня скину на ЯД
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Автор - FERZb
Дата добавления - 11.10.2017 в 13:37
FERZb Дата: Среда, 11.10.2017, 14:08 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Где? Покажите в файле

Всё заработало, спасибо на ЯД
 
Ответить
Сообщение
Где? Покажите в файле

Всё заработало, спасибо на ЯД

Автор - FERZb
Дата добавления - 11.10.2017 в 14:08
FERZb Дата: Среда, 11.10.2017, 14:28 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
хотя...

Вот с этой формулой у меня какая то магия(
Код

=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))

Ставлю значение 44 100 он начинает считать какие то фантастические миллионы Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума


Сообщение отредактировал FERZb - Среда, 11.10.2017, 14:42
 
Ответить
Сообщениехотя...

Вот с этой формулой у меня какая то магия(
Код

=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))

Ставлю значение 44 100 он начинает считать какие то фантастические миллионы Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума

Автор - FERZb
Дата добавления - 11.10.2017 в 14:28
_Boroda_ Дата: Среда, 11.10.2017, 14:30 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)
- Приложите файл в формате Excel размером до 100кб согласно п.3 Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)
- Приложите файл в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - _Boroda_
Дата добавления - 11.10.2017 в 14:30
FERZb Дата: Среда, 11.10.2017, 14:34 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))


Я извиняюсь, что пишу не то и не так, очень давно тут не был(

Файл очень большой, больше 100кб (7 МБ)


Сообщение отредактировал FERZb - Среда, 11.10.2017, 14:35
 
Ответить
Сообщение
Код
=ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<3000;;ЕСЛИ(D2*ПОДСТАВИТЬ(A2;".";",")<20000;D2*ПОДСТАВИТЬ(A2;".";",");ЕСЛИ(D2*ПОДСТАВИТЬ(B2;".";",")<100000;D2*ПОДСТАВИТЬ(B2;".";",");D2*ПОДСТАВИТЬ(C2;".";","))))


Я извиняюсь, что пишу не то и не так, очень давно тут не был(

Файл очень большой, больше 100кб (7 МБ)

Автор - FERZb
Дата добавления - 11.10.2017 в 14:34
_Boroda_ Дата: Среда, 11.10.2017, 14:53 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ставлю значение 44 100
Ставите куда?
Файл очень большой
Весь файл и не нужен. Кусок покажите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Ставлю значение 44 100
Ставите куда?
Файл очень большой
Весь файл и не нужен. Кусок покажите

Автор - _Boroda_
Дата добавления - 11.10.2017 в 14:53
FERZb Дата: Среда, 11.10.2017, 14:55 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Весь файл и не нужен. Кусок покажите


Я прошу прощения за сумбур :(

Формулы заработали все - но почему то не сходиться сумма при использовании формул

Во вложении пример с оригинальной разметкой ячеек и полей
К сообщению приложен файл: 5685235.xlsx(10Kb)
 
Ответить
Сообщение
Весь файл и не нужен. Кусок покажите


Я прошу прощения за сумбур :(

Формулы заработали все - но почему то не сходиться сумма при использовании формул

Во вложении пример с оригинальной разметкой ячеек и полей

Автор - FERZb
Дата добавления - 11.10.2017 в 14:55
_Boroda_ Дата: Среда, 11.10.2017, 15:02 | Сообщение № 18
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Эти цены и не должны сходиться - верхняя выбирает столбец для расчета исходя из общей суммы (один столбеу для всех количеств), а нижние формулы выбирают для каждого количества свой столбец.
Совпасть может, но только в том случае, когда каждая цена будет из одного и того же столбца (все цены будут браться из одного столбца)
А у Вас в файле первая строке берет цену из G, а вторая из F
Вообще забудьте про формулу из ячейки I2 - она Вам в этой задаче не подходит


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭти цены и не должны сходиться - верхняя выбирает столбец для расчета исходя из общей суммы (один столбеу для всех количеств), а нижние формулы выбирают для каждого количества свой столбец.
Совпасть может, но только в том случае, когда каждая цена будет из одного и того же столбца (все цены будут браться из одного столбца)
А у Вас в файле первая строке берет цену из G, а вторая из F
Вообще забудьте про формулу из ячейки I2 - она Вам в этой задаче не подходит

Автор - _Boroda_
Дата добавления - 11.10.2017 в 15:02
FERZb Дата: Среда, 11.10.2017, 18:17 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вообще забудьте про формулу из ячейки I2 - она Вам в этой задаче не подходит

А какой вариант лучше тогда?

И ещё вопрос по формуле - в ячейке I6 изменяя сумму больше 21 шт формула сбивается появляется ошибка ЗНАЧ
 
Ответить
Сообщение
Вообще забудьте про формулу из ячейки I2 - она Вам в этой задаче не подходит

А какой вариант лучше тогда?

И ещё вопрос по формуле - в ячейке I6 изменяя сумму больше 21 шт формула сбивается появляется ошибка ЗНАЧ

Автор - FERZb
Дата добавления - 11.10.2017 в 18:17
_Boroda_ Дата: Среда, 11.10.2017, 19:59 | Сообщение № 20
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если
Проверка происходит не по общей сумме заказа а по сумме заказа по каждой позиции прайса
, то конечно второй

формула сбивается появляется ошибка ЗНАЧ
Правильно. Почему там у Вас ссылка на I3, а не на I6?
И вообще, если там у Вас не будет цен с точкой вместо запятой, то ПОДСТАВИТЬ там не нужно. Тогда вот так напишите
Код
=ЕСЛИ(I5*F5<3000;;ЕСЛИ(I5*F5<20000;I5*F5;ЕСЛИ(I5*G5<100000;I5*G5;I5*H5)))
К сообщению приложен файл: 5685235_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли
Проверка происходит не по общей сумме заказа а по сумме заказа по каждой позиции прайса
, то конечно второй

формула сбивается появляется ошибка ЗНАЧ
Правильно. Почему там у Вас ссылка на I3, а не на I6?
И вообще, если там у Вас не будет цен с точкой вместо запятой, то ПОДСТАВИТЬ там не нужно. Тогда вот так напишите
Код
=ЕСЛИ(I5*F5<3000;;ЕСЛИ(I5*F5<20000;I5*F5;ЕСЛИ(I5*G5<100000;I5*G5;I5*H5)))

Автор - _Boroda_
Дата добавления - 11.10.2017 в 19:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт цены исходя из суммы заказа (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!