Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Гистограмма показывает не верные данные, если в ячейках нули - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гистограмма показывает не верные данные, если в ячейках нули (Формулы/Formulas)
Гистограмма показывает не верные данные, если в ячейках нули
awaddwaawddw Дата: Вторник, 06.03.2018, 02:09 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Добрый вечер!

Гистограмма показывает не верные данные, если в ячейках нули или формулы.
У меня в ячейках прописаны формулы из за которых гистограмма нарушается. А мне нужно чтобы она не нарушалась.
К сообщению приложен файл: primer06032018.xlsx(11.1 Kb)
 
Ответить
СообщениеДобрый вечер!

Гистограмма показывает не верные данные, если в ячейках нули или формулы.
У меня в ячейках прописаны формулы из за которых гистограмма нарушается. А мне нужно чтобы она не нарушалась.

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 02:09
китин Дата: Вторник, 06.03.2018, 07:24 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5037
Репутация: 802 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а если через ЕСЛИ?
Код
=ЕСЛИ(B21="";"";B21)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа если через ЕСЛИ?
Код
=ЕСЛИ(B21="";"";B21)

Автор - китин
Дата добавления - 06.03.2018 в 07:24
awaddwaawddw Дата: Вторник, 06.03.2018, 13:21 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Спасибо Игорь помогло!
 
Ответить
СообщениеСпасибо Игорь помогло!

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 13:21
awaddwaawddw Дата: Вторник, 06.03.2018, 13:50 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Столкнулся с подобной проблемой немного в другом виде.

Если в ячейке стоит данная формула
Код
=(B26-B25)*100/B26

Она выводит не ноль, а #ДЕЛ/0 из за чего сталкиваюсь с такой же проблемой.

Как преобразовать формулу
Код
=(B26-B25)*100/B26
К сообщению приложен файл: primer06032018_.xlsx(11.5 Kb)


Сообщение отредактировал awaddwaawddw - Вторник, 06.03.2018, 13:54
 
Ответить
СообщениеСтолкнулся с подобной проблемой немного в другом виде.

Если в ячейке стоит данная формула
Код
=(B26-B25)*100/B26

Она выводит не ноль, а #ДЕЛ/0 из за чего сталкиваюсь с такой же проблемой.

Как преобразовать формулу
Код
=(B26-B25)*100/B26

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 13:50
sboy Дата: Вторник, 06.03.2018, 13:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
точно так же
Код
=ЕСЛИ(B26="";"";(B26-B25)*100/B26)


Сообщение отредактировал sboy - Вторник, 06.03.2018, 13:55
 
Ответить
СообщениеДобрый день.
точно так же
Код
=ЕСЛИ(B26="";"";(B26-B25)*100/B26)

Автор - sboy
Дата добавления - 06.03.2018 в 13:55
awaddwaawddw Дата: Вторник, 06.03.2018, 13:57 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Спасибо Sboy всё работает!
 
Ответить
СообщениеСпасибо Sboy всё работает!

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 13:57
Pelena Дата: Вторник, 06.03.2018, 13:58 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Не хотите отрицательные другим цветом сделать?
К сообщению приложен файл: 5861482.xlsx(12.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе хотите отрицательные другим цветом сделать?

Автор - Pelena
Дата добавления - 06.03.2018 в 13:58
awaddwaawddw Дата: Вторник, 06.03.2018, 14:21 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Пелена хочу! Только я скачал файл, не увидел там разнице, может из за моей версии 2007.

У меня ещё одна производная данной проблемы вот третий вариант, почему гистограмма не работает. Как в данном варианте решить проблему?
К сообщению приложен файл: primer06032018v.xlsx(12.0 Kb)


Сообщение отредактировал awaddwaawddw - Вторник, 06.03.2018, 14:24
 
Ответить
СообщениеПелена хочу! Только я скачал файл, не увидел там разнице, может из за моей версии 2007.

У меня ещё одна производная данной проблемы вот третий вариант, почему гистограмма не работает. Как в данном варианте решить проблему?

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 14:21
Pelena Дата: Вторник, 06.03.2018, 14:38 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
может из за моей версии 2007
Очень может быть

Ну Вы бы в формулу вникли немного
Код
=ЕСЛИ(B6>0;(B6-B5)*100/B6;"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
может из за моей версии 2007
Очень может быть

Ну Вы бы в формулу вникли немного
Код
=ЕСЛИ(B6>0;(B6-B5)*100/B6;"")

Автор - Pelena
Дата добавления - 06.03.2018 в 14:38
awaddwaawddw Дата: Вторник, 06.03.2018, 15:48 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
А при функции сумм, выскакивает подобная проблема. Как в ней быть?
К сообщению приложен файл: 8652315.xlsx(11.6 Kb)
 
Ответить
СообщениеА при функции сумм, выскакивает подобная проблема. Как в ней быть?

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 15:48
китин Дата: Вторник, 06.03.2018, 15:51 | Сообщение № 11
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5037
Репутация: 802 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Как в ней быть?

Точно так же
Код
=ЕСЛИ(СУММ(A26:B26)=0;"";СУММ(A26:B26))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Как в ней быть?

Точно так же
Код
=ЕСЛИ(СУММ(A26:B26)=0;"";СУММ(A26:B26))

Автор - китин
Дата добавления - 06.03.2018 в 15:51
sboy Дата: Вторник, 06.03.2018, 15:52 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
Как в ней быть?

точно также как и при умножении, делении и прочем.
Проверяйте сначала ячейки на данные
 
Ответить
Сообщение
Как в ней быть?

точно также как и при умножении, делении и прочем.
Проверяйте сначала ячейки на данные

Автор - sboy
Дата добавления - 06.03.2018 в 15:52
awaddwaawddw Дата: Вторник, 06.03.2018, 19:52 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
А как с СРЗНАЧ ? он выводит в столбце где гистограмма, выводит мне #ДЕЛ/0

Код
=СРЗНАЧ(A26:C26)
К сообщению приложен файл: srznasc.xlsx(11.5 Kb)
 
Ответить
СообщениеА как с СРЗНАЧ ? он выводит в столбце где гистограмма, выводит мне #ДЕЛ/0

Код
=СРЗНАЧ(A26:C26)

Автор - awaddwaawddw
Дата добавления - 06.03.2018 в 19:52
Che79 Дата: Вторник, 06.03.2018, 20:44 | Сообщение № 14
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Если правильно понял. Формула массива
Код
=ЕСЛИ(И(A26:C26=0);"";СРЗНАЧ(A26:C26))
К сообщению приложен файл: 9470967.xlsx(12.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЕсли правильно понял. Формула массива
Код
=ЕСЛИ(И(A26:C26=0);"";СРЗНАЧ(A26:C26))

Автор - Che79
Дата добавления - 06.03.2018 в 20:44
awaddwaawddw Дата: Среда, 07.03.2018, 00:26 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Che79 данная формула работает если нет в ячейках формул.

А вот если там формулы то не работает уже. Приложил пример. Может кто знает как решить?
К сообщению приложен файл: voprosces.xlsx(11.9 Kb)
 
Ответить
СообщениеChe79 данная формула работает если нет в ячейках формул.

А вот если там формулы то не работает уже. Приложил пример. Может кто знает как решить?

Автор - awaddwaawddw
Дата добавления - 07.03.2018 в 00:26
Che79 Дата: Среда, 07.03.2018, 01:51 | Сообщение № 16
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Так?
Код
=ЕСЛИ(C26="";"";СРЗНАЧ(C26:C32))


Делай нормально и будет нормально!
 
Ответить
СообщениеТак?
Код
=ЕСЛИ(C26="";"";СРЗНАЧ(C26:C32))

Автор - Che79
Дата добавления - 07.03.2018 в 01:51
awaddwaawddw Дата: Среда, 07.03.2018, 02:58 | Сообщение № 17
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 7 ±
Замечаний: 20% ±

Excel 2007
Che79 да то что нужно БЛАГОДАРЮ!

Ещё раз всем спасибо!
 
Ответить
СообщениеChe79 да то что нужно БЛАГОДАРЮ!

Ещё раз всем спасибо!

Автор - awaddwaawddw
Дата добавления - 07.03.2018 в 02:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гистограмма показывает не верные данные, если в ячейках нули (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!