Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных на другой лист по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на другой лист по условию (Формулы/Formulas)
Перенос данных на другой лист по условию
Snow Дата: Пятница, 26.02.2016, 13:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
yes Здрасьте!
Помогите формулой :)
Нужно, чтобы вся строка с данными (при соблюдении условия) копировалась на лист2
К сообщению приложен файл: 0412971.xls(34Kb)


Сообщение отредактировал Snow - Пятница, 26.02.2016, 16:34
 
Ответить
Сообщениеyes Здрасьте!
Помогите формулой :)
Нужно, чтобы вся строка с данными (при соблюдении условия) копировалась на лист2

Автор - Snow
Дата добавления - 26.02.2016 в 13:45
китин Дата: Пятница, 26.02.2016, 22:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$L$8;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$H$2:$H$8);СТРОКА(Лист1!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Лист1!$A$1:$L$1;0));0)
К сообщению приложен файл: Snow.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$L$8;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$H$2:$H$8);СТРОКА(Лист1!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Лист1!$A$1:$L$1;0));0)

Автор - китин
Дата добавления - 26.02.2016 в 22:11
Snow Дата: Понедельник, 29.02.2016, 15:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
пытаюсь переместить в свой файл. никак не выходит :'(
меняю диапазон массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('2016'!$A$5:$P$1100;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО('2016'!$I$5:$I$1100);СТРОКА('2016'!$A$5:$A$1100)-1);СТРОКА(A2));ПОИСКПОЗ(A$2;'2016'!$A$2:$P$2;0));0)

что я не так делаю? :(
К сообщению приложен файл: 1450904.xlsx(14Kb)


Сообщение отредактировал Serge_007 - Понедельник, 29.02.2016, 20:24
 
Ответить
Сообщениепытаюсь переместить в свой файл. никак не выходит :'(
меняю диапазон массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('2016'!$A$5:$P$1100;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО('2016'!$I$5:$I$1100);СТРОКА('2016'!$A$5:$A$1100)-1);СТРОКА(A2));ПОИСКПОЗ(A$2;'2016'!$A$2:$P$2;0));0)

что я не так делаю? :(

Автор - Snow
Дата добавления - 29.02.2016 в 15:55
китин Дата: Понедельник, 29.02.2016, 16:31 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
вводится тремя клавишами Ctrl Shift Enter
СТРОКА('2016'!$A$5:$A$1100)-1

поменяете 1 на 4
а еще лучше кусок рельного файла приложите.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 29.02.2016, 16:36
 
Ответить
Сообщение
формула массива
вводится тремя клавишами Ctrl Shift Enter
СТРОКА('2016'!$A$5:$A$1100)-1

поменяете 1 на 4
а еще лучше кусок рельного файла приложите.

Автор - китин
Дата добавления - 29.02.2016 в 16:31
Snow Дата: Понедельник, 29.02.2016, 16:58 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
:'(
К сообщению приложен файл: 2647272.xlsx(16Kb)
 
Ответить
Сообщение:'(

Автор - Snow
Дата добавления - 29.02.2016 в 16:58
_Boroda_ Дата: Понедельник, 29.02.2016, 17:20 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
2 типа формул
Розовые хватают значение из листа 1 из ячеек выше
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА(Лист1!A$1:A$99);СТРОКА(Лист1!A$1:A$99)/(Лист1!A$1:A$99<>"");Лист1!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$H$6:$H$99;СТРОКА(Лист1!H$6:H$99));СТРОКА(A1)));"")

Заленые - просто тупо тянут то, что нашли
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!H$1:H$99;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$H$6:$H$99;СТРОКА(Лист1!O$6:O$99));СТРОКА(F1)));"")
К сообщению приложен файл: 2647272_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение2 типа формул
Розовые хватают значение из листа 1 из ячеек выше
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА(Лист1!A$1:A$99);СТРОКА(Лист1!A$1:A$99)/(Лист1!A$1:A$99<>"");Лист1!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$H$6:$H$99;СТРОКА(Лист1!H$6:H$99));СТРОКА(A1)));"")

Заленые - просто тупо тянут то, что нашли
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!H$1:H$99;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$H$6:$H$99;СТРОКА(Лист1!O$6:O$99));СТРОКА(F1)));"")

Автор - _Boroda_
Дата добавления - 29.02.2016 в 17:20
TimSha Дата: Понедельник, 29.02.2016, 17:28 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 456
Репутация: 73 ±
Замечаний: 0% ±

Excel 2013 Pro +
Вариант (для ленивых) - расширенный фильтр, вызывать с листа, на который надо вывести данные... ;)
К сообщению приложен файл: 4507616.xls(72Kb)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

Сообщение отредактировал TimSha - Понедельник, 29.02.2016, 17:28
 
Ответить
СообщениеВариант (для ленивых) - расширенный фильтр, вызывать с листа, на который надо вывести данные... ;)

Автор - TimSha
Дата добавления - 29.02.2016 в 17:28
Snow Дата: Вторник, 01.03.2016, 13:59 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
в ваших файлах работает, в моем -нет :'( :'(
не ругайтесь :( , я не понимаю как формулу перенести?
меняю название листа и пустая строка получается

вводится тремя клавишами Ctrl Shift Enter

так вообще ничего не происходит

вот что вставляется в мой файл :deal:
Код
2=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА([2647272_1.xlsx]Лист1!A$1:A$99);СТРОКА([2647272_1.xlsx]Лист1!A$1:A$99)/([2647272_1.xlsx]Лист1!A$1:A$99<>"");[2647272_1.xlsx]Лист1!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ([2647272_1.xlsx]Лист1!$H$6:$H$99;СТРОКА([2647272_1.xlsx]Лист1!H$6:H$99));СТРОКА(A2)));"")

что нужно поменять, чтобы сменить лист? [2647272_1.xlsx]Лист1! заменяю на название своего листа.так?

ли сменить столбец, например

при открытии вот что пишет: (картинки)
К сообщению приложен файл: 6747286.jpg(10Kb) · 7490081.jpg(24Kb)


Сообщение отредактировал Snow - Вторник, 01.03.2016, 14:06
 
Ответить
Сообщениев ваших файлах работает, в моем -нет :'( :'(
не ругайтесь :( , я не понимаю как формулу перенести?
меняю название листа и пустая строка получается

вводится тремя клавишами Ctrl Shift Enter

так вообще ничего не происходит

вот что вставляется в мой файл :deal:
Код
2=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА([2647272_1.xlsx]Лист1!A$1:A$99);СТРОКА([2647272_1.xlsx]Лист1!A$1:A$99)/([2647272_1.xlsx]Лист1!A$1:A$99<>"");[2647272_1.xlsx]Лист1!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ([2647272_1.xlsx]Лист1!$H$6:$H$99;СТРОКА([2647272_1.xlsx]Лист1!H$6:H$99));СТРОКА(A2)));"")

что нужно поменять, чтобы сменить лист? [2647272_1.xlsx]Лист1! заменяю на название своего листа.так?

ли сменить столбец, например

при открытии вот что пишет: (картинки)

Автор - Snow
Дата добавления - 01.03.2016 в 13:59
_Boroda_ Дата: Вторник, 01.03.2016, 14:05 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Копировать можно не только из файла, но и из поста, который на форуме.
2.
[2647272_1.xlsx]Лист1! заменяю на название своего листа.так?
Почти. Знак ! не трогайте и, если у Вас лист не в одно слово, то в одинарные кавычки его. Вот так
Код
='Лист 3'!D17

3. Почему Вы не приложили файл с реальными названиями листов?
4 .Откуда взялась двойка в начале формулы?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Копировать можно не только из файла, но и из поста, который на форуме.
2.
[2647272_1.xlsx]Лист1! заменяю на название своего листа.так?
Почти. Знак ! не трогайте и, если у Вас лист не в одно слово, то в одинарные кавычки его. Вот так
Код
='Лист 3'!D17

3. Почему Вы не приложили файл с реальными названиями листов?
4 .Откуда взялась двойка в начале формулы?

Автор - _Boroda_
Дата добавления - 01.03.2016 в 14:05
Snow Дата: Вторник, 01.03.2016, 14:19 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Откуда взялась двойка в начале формулы?

двойка случайно прицепилась ))
Почему Вы не приложили файл с реальными названиями листов?

2016 лист называется, я вкладывала.
К сообщению приложен файл: 1450904.xlsx(14Kb)


Копировать можно не только из файла, но и из поста, который на форуме.

из поста тоже копировала, не получается
 
Ответить
Сообщение
Откуда взялась двойка в начале формулы?

двойка случайно прицепилась ))
Почему Вы не приложили файл с реальными названиями листов?

2016 лист называется, я вкладывала.
К сообщению приложен файл: 1450904.xlsx(14Kb)


Копировать можно не только из файла, но и из поста, который на форуме.

из поста тоже копировала, не получается

Автор - Snow
Дата добавления - 01.03.2016 в 14:19
_Boroda_ Дата: Вторник, 01.03.2016, 14:30 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Подождите, это у Вас файл как-то коряво загрузился. Попробуйте вот с этим. Лист я там переименовал.
К сообщению приложен файл: 2647272_2.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПодождите, это у Вас файл как-то коряво загрузился. Попробуйте вот с этим. Лист я там переименовал.

Автор - _Boroda_
Дата добавления - 01.03.2016 в 14:30
Snow Дата: Вторник, 01.03.2016, 14:36 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
2647272_2.xlsx файл при открытии пишет то же самое
К сообщению приложен файл: 5113340.xlsx(72Kb)


Сообщение отредактировал Snow - Вторник, 01.03.2016, 14:39
 
Ответить
Сообщение2647272_2.xlsx файл при открытии пишет то же самое

Автор - Snow
Дата добавления - 01.03.2016 в 14:36
_Boroda_ Дата: Вторник, 01.03.2016, 14:41 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Какой негодяй!

А так?
К сообщению приложен файл: 9898987.xlsx(15Kb) · 9898987.xls(58Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКакой негодяй!

А так?

Автор - _Boroda_
Дата добавления - 01.03.2016 в 14:41
Snow Дата: Вторник, 01.03.2016, 14:59 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
я уж думала, вы меня вообще ненавидите за то, что я к вам тут пристаю :)
не могу перенести в свой ехеl, замучилась вся. >(

как столбец сменить? заменяю H на I и все портится снова (((
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА('2016'!A$1:A$99);СТРОКА('2016'!A$1:A$99)/('2016'!A$1:A$99<>"");'2016'!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ('2016'!$H$6:$H$99;СТРОКА('2016'!H$6:H$99));СТРОКА(A1)));"")

здесь менять? НАИМЕНЬШИЙ(ЕСЛИ('2016'!$H$6:$H$99;СТРОКА
 
Ответить
Сообщениея уж думала, вы меня вообще ненавидите за то, что я к вам тут пристаю :)
не могу перенести в свой ехеl, замучилась вся. >(

как столбец сменить? заменяю H на I и все портится снова (((
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПРОСМОТР(СТРОКА('2016'!A$1:A$99);СТРОКА('2016'!A$1:A$99)/('2016'!A$1:A$99<>"");'2016'!A$1:A$99);НАИМЕНЬШИЙ(ЕСЛИ('2016'!$H$6:$H$99;СТРОКА('2016'!H$6:H$99));СТРОКА(A1)));"")

здесь менять? НАИМЕНЬШИЙ(ЕСЛИ('2016'!$H$6:$H$99;СТРОКА

Автор - Snow
Дата добавления - 01.03.2016 в 14:59
_Boroda_ Дата: Вторник, 01.03.2016, 15:03 | Сообщение № 15
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, здесь. И после замены нажать Контрл Шифт Ентер


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, здесь. И после замены нажать Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 01.03.2016 в 15:03
Snow Дата: Вторник, 01.03.2016, 15:13 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
hands hands hands hands hands
К сообщению приложен файл: 3061617.jpg(31Kb)
 
Ответить
Сообщениеhands hands hands hands hands

Автор - Snow
Дата добавления - 01.03.2016 в 15:13
Snow Дата: Вторник, 01.03.2016, 15:14 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
я, видимо, просто не знала, куда тыкать Контрл Шифт Ентер


Сообщение отредактировал Snow - Вторник, 01.03.2016, 15:15
 
Ответить
Сообщениея, видимо, просто не знала, куда тыкать Контрл Шифт Ентер

Автор - Snow
Дата добавления - 01.03.2016 в 15:14
Aleks17 Дата: Воскресенье, 13.03.2016, 20:56 | Сообщение № 18
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Плиз!!!! Помогите)
Есть файл на десятки тысяч слов, по несколько в каждой строке. Необходимо сделать так, чтоб каждая фраза из нескольких слов разбилась по словам, каждое из которых перенесется на новую строку ( ориентировочно привязка будет к пробелам, т.е. после пробела слово переносится.
Если есть 20 строк по 2 слова на каждой, то должно получится 40 строк.
Спасибо всем за помощь!!!
[moder]Вопрос не относится к данной теме. Читаем Правила форума, создаём свою тему, прикладываем файл-пример[/moder]


Сообщение отредактировал Pelena - Воскресенье, 13.03.2016, 20:58
 
Ответить
СообщениеДобрый день!
Плиз!!!! Помогите)
Есть файл на десятки тысяч слов, по несколько в каждой строке. Необходимо сделать так, чтоб каждая фраза из нескольких слов разбилась по словам, каждое из которых перенесется на новую строку ( ориентировочно привязка будет к пробелам, т.е. после пробела слово переносится.
Если есть 20 строк по 2 слова на каждой, то должно получится 40 строк.
Спасибо всем за помощь!!!
[moder]Вопрос не относится к данной теме. Читаем Правила форума, создаём свою тему, прикладываем файл-пример[/moder]

Автор - Aleks17
Дата добавления - 13.03.2016 в 20:56
Iha Дата: Четверг, 17.03.2016, 09:45 | Сообщение № 19
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день!
Очень нужна помощь!
Есть лист с данными из него нужно перенести все строки, удовлетворяющие условию по колонке сумма долга(=0) на новый лист. Понимаю что должна работать формула ИНДЕКС, только что-то с ней не клеится.
[moder]Ирина, согласно Правилам форума, Вам необходимо создать свою тему.
А в формуле у Вас все почти правильно
К сообщению приложен файл: 17032016.xlsx(12Kb)
 
Ответить
СообщениеДобрый день!
Очень нужна помощь!
Есть лист с данными из него нужно перенести все строки, удовлетворяющие условию по колонке сумма долга(=0) на новый лист. Понимаю что должна работать формула ИНДЕКС, только что-то с ней не клеится.
[moder]Ирина, согласно Правилам форума, Вам необходимо создать свою тему.
А в формуле у Вас все почти правильно

Автор - Iha
Дата добавления - 17.03.2016 в 09:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на другой лист по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!