Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование времени в формате д. ч. м. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование времени в формате д. ч. м. (Формулы/Formulas)
Суммирование времени в формате д. ч. м.
sneper Дата: Четверг, 25.08.2016, 16:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Просьба помочь в такой задаче. Нужно суммировать время в формате д. ч. м.. Пример данных в ячейке может быть таким (15д. 20ч. 14м., 2ч. 21м., 50м.).
Приложил к теме пример файла.
В итоге должно быть выражение такого же формата - 15д. 20ч. 14м.
К сообщению приложен файл: Example.xlsx(14Kb)


Сообщение отредактировал sneper - Четверг, 25.08.2016, 16:34
 
Ответить
СообщениеДобрый день.
Просьба помочь в такой задаче. Нужно суммировать время в формате д. ч. м.. Пример данных в ячейке может быть таким (15д. 20ч. 14м., 2ч. 21м., 50м.).
Приложил к теме пример файла.
В итоге должно быть выражение такого же формата - 15д. 20ч. 14м.

Автор - sneper
Дата добавления - 25.08.2016 в 16:20
Pelena Дата: Четверг, 25.08.2016, 17:05 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Чтобы сильно не усложнять формулу, вариант с доп. столбцами
К сообщению приложен файл: 8621347.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Чтобы сильно не усложнять формулу, вариант с доп. столбцами

Автор - Pelena
Дата добавления - 25.08.2016 в 17:05
sboy Дата: Четверг, 25.08.2016, 17:20 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 49 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Применил "текст по столбцам" по разделителю "."
формулы не такие красивые, как у Pelena
К сообщению приложен файл: Example-1-.xlsx(11Kb)
 
Ответить
СообщениеДобрый день.
Применил "текст по столбцам" по разделителю "."
формулы не такие красивые, как у Pelena

Автор - sboy
Дата добавления - 25.08.2016 в 17:20
buchlotnik Дата: Четверг, 25.08.2016, 17:26 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Чтобы сильно не усложнять формулу
зато смотрится-то как классно yes
(попаразитировал на формулах Елены)
К сообщению приложен файл: 3043360.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 25.08.2016, 17:29
 
Ответить
Сообщение
Цитата
Чтобы сильно не усложнять формулу
зато смотрится-то как классно yes
(попаразитировал на формулах Елены)

Автор - buchlotnik
Дата добавления - 25.08.2016 в 17:26
sboy Дата: Четверг, 25.08.2016, 17:40 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 49 ±
Замечаний: 0% ±

Excel 2007
еще вариант:
Делаем в столбце 3 замены: д. на *1440+, ч. на *60+, м. на ""
и с помощью макрофункции Вычислить()

хотя можно без макрофункции. после замены в соседний столбец формулу
Код
="="&C2

потом копировать- вставить значения, текст по столбцам-готово
К сообщению приложен файл: Example-1-.xlsm(10Kb)


Сообщение отредактировал sboy - Четверг, 25.08.2016, 17:52
 
Ответить
Сообщениееще вариант:
Делаем в столбце 3 замены: д. на *1440+, ч. на *60+, м. на ""
и с помощью макрофункции Вычислить()

хотя можно без макрофункции. после замены в соседний столбец формулу
Код
="="&C2

потом копировать- вставить значения, текст по столбцам-готово

Автор - sboy
Дата добавления - 25.08.2016 в 17:40
Pelena Дата: Четверг, 25.08.2016, 18:28 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
[offtop]
зато смотрится-то как классно

Михаил, [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]
зато смотрится-то как классно

Михаил, [/offtop]

Автор - Pelena
Дата добавления - 25.08.2016 в 18:28
sneper Дата: Пятница, 26.08.2016, 14:04 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Самым оптимальным оказался вариант Pelena. Так как есть множество таблиц с этим временем. И складывать проще в этом варианте.
Всё равно всем огромное спасибо за участие.
Так же хотел внести маленькое уточнение и задать вопрос. Возможно ещё добавить один столбик к варианту Pelena с указание секунд? Так как начали такие варианты встречаться. Пример выражений может быть таким 5д. 15ч. 48м. 12с., 2ч. 29м. 23с., 45м. 13с.
К сообщению приложен файл: 9624190.xlsx(16Kb)


Сообщение отредактировал sneper - Пятница, 26.08.2016, 14:38
 
Ответить
СообщениеСамым оптимальным оказался вариант Pelena. Так как есть множество таблиц с этим временем. И складывать проще в этом варианте.
Всё равно всем огромное спасибо за участие.
Так же хотел внести маленькое уточнение и задать вопрос. Возможно ещё добавить один столбик к варианту Pelena с указание секунд? Так как начали такие варианты встречаться. Пример выражений может быть таким 5д. 15ч. 48м. 12с., 2ч. 29м. 23с., 45м. 13с.

Автор - sneper
Дата добавления - 26.08.2016 в 14:04
pabchek Дата: Пятница, 26.08.2016, 14:56 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Мой вариант с единой (протягиваемой) формулой. Ну и секунды добавил
Код
=ЕСЛИОШИБКА(--ИНДЕКС(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);C$1);0)


Подправил
Код
=ЕСЛИОШИБКА(--ИНДЕКС(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);СТОЛБЕЦ(A1));0)

и сумму перезалил
ну и общую формулу добавил

а вобщето... вот массивная формула
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);0)/{1;24;1440;86400})
К сообщению приложен файл: 6269272.xlsx(17Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 26.08.2016, 15:19
 
Ответить
СообщениеМой вариант с единой (протягиваемой) формулой. Ну и секунды добавил
Код
=ЕСЛИОШИБКА(--ИНДЕКС(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);C$1);0)


Подправил
Код
=ЕСЛИОШИБКА(--ИНДЕКС(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);СТОЛБЕЦ(A1));0)

и сумму перезалил
ну и общую формулу добавил

а вобщето... вот массивная формула
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(" "&$B2;ПОИСК({"д";"ч";"м";"с"};" "&$B2)-2;2);0)/{1;24;1440;86400})

Автор - pabchek
Дата добавления - 26.08.2016 в 14:56
sneper Дата: Пятница, 26.08.2016, 15:24 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
pabchek, в самой главной ячейке - итог, знак вопроса стоит.


Сообщение отредактировал sneper - Пятница, 26.08.2016, 15:25
 
Ответить
Сообщениеpabchek, в самой главной ячейке - итог, знак вопроса стоит.

Автор - sneper
Дата добавления - 26.08.2016 в 15:24
pabchek Дата: Пятница, 26.08.2016, 16:31 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
ну так получайте!! :)
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(" "&B2:B26;ПОИСК({"д";"ч";"м";"с"};" "&B2:B26)-2;2);0)/{1;24;1440;86400})

[offtop]в самом деле... чёто сразу как пошли все по допстолбцам. А формулу-то можно и одну написать)))[/offtop]
добавил
если нужно в Вашем формате, добавил секунды в формулу Лены
К сообщению приложен файл: 9267141.xlsx(14Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 26.08.2016, 16:42
 
Ответить
Сообщениену так получайте!! :)
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(" "&B2:B26;ПОИСК({"д";"ч";"м";"с"};" "&B2:B26)-2;2);0)/{1;24;1440;86400})

[offtop]в самом деле... чёто сразу как пошли все по допстолбцам. А формулу-то можно и одну написать)))[/offtop]
добавил
если нужно в Вашем формате, добавил секунды в формулу Лены

Автор - pabchek
Дата добавления - 26.08.2016 в 16:31
Pelena Дата: Пятница, 26.08.2016, 16:36 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Виктор, автор имеет в виду, что
В итоге должно быть выражение такого же формата - 15д. 20ч. 14м.


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВиктор, автор имеет в виду, что
В итоге должно быть выражение такого же формата - 15д. 20ч. 14м.

Автор - Pelena
Дата добавления - 26.08.2016 в 16:36
pabchek Дата: Пятница, 26.08.2016, 16:38 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Уже поправился, перезалил))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеУже поправился, перезалил))

Автор - pabchek
Дата добавления - 26.08.2016 в 16:38
Pelena Дата: Пятница, 26.08.2016, 16:57 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
добавить один столбик

Думаю, уже не актуально, но отвечу
[p.s.]Кстати, результат разный[/p.s.]
К сообщению приложен файл: 4566282.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
добавить один столбик

Думаю, уже не актуально, но отвечу
[p.s.]Кстати, результат разный[/p.s.]

Автор - Pelena
Дата добавления - 26.08.2016 в 16:57
pabchek Дата: Пятница, 26.08.2016, 17:09 | Сообщение № 14
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Кстати, результат разный

Там и данные разные
А что касается формата... то вот и формат
Код
ГГ"г. "ММ"мес. "ДД"д.  " чч"ч. "мм"мин. "сс"с."
К сообщению приложен файл: 0591033.xlsx(14Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение
Кстати, результат разный

Там и данные разные
А что касается формата... то вот и формат
Код
ГГ"г. "ММ"мес. "ДД"д.  " чч"ч. "мм"мин. "сс"с."

Автор - pabchek
Дата добавления - 26.08.2016 в 17:09
Pelena Дата: Пятница, 26.08.2016, 17:11 | Сообщение № 15
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Там и данные разные

Вы не поверите :D я таки проверила на одинаковых данных на файле из поста№7 (или 13)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Там и данные разные

Вы не поверите :D я таки проверила на одинаковых данных на файле из поста№7 (или 13)

Автор - Pelena
Дата добавления - 26.08.2016 в 17:11
pabchek Дата: Пятница, 26.08.2016, 17:24 | Сообщение № 16
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Кстати, результат разный

И Вы абсолютно правы. В исходном примере максимальное число дней было двузначным, а потом появились 3-х значные. Исправляю:
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(ПОДСТАВИТЬ(" "&B2:B24;" ";"   ");ПОИСК({"д";"ч";"м";"с"};ПОДСТАВИТЬ(" "&B2:B24;" ";"   "))-3;3);0)/{1;24;1440;86400})
К сообщению приложен файл: 7645558.xlsx(14Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение
Кстати, результат разный

И Вы абсолютно правы. В исходном примере максимальное число дней было двузначным, а потом появились 3-х значные. Исправляю:
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(ПОДСТАВИТЬ(" "&B2:B24;" ";"   ");ПОИСК({"д";"ч";"м";"с"};ПОДСТАВИТЬ(" "&B2:B24;" ";"   "))-3;3);0)/{1;24;1440;86400})

Автор - pabchek
Дата добавления - 26.08.2016 в 17:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование времени в формате д. ч. м. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!