Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическая сортировка по трем критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая сортировка по трем критериям (Формулы/Formulas)
Автоматическая сортировка по трем критериям
ASnin Дата: Пятница, 12.05.2017, 06:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не смог найти решение к своей проблеме. Нужна сортировка по трем критериям. День/ночь -> кол-во от большего к меньшему, если совпадает, то -> ФИО в алфавитном порядке. Прикладываю пример. Сама таблица очень большая.
К сообщению приложен файл: 4107652.xlsx(8Kb)


Сообщение отредактировал ASnin - Пятница, 12.05.2017, 06:31
 
Ответить
СообщениеНе смог найти решение к своей проблеме. Нужна сортировка по трем критериям. День/ночь -> кол-во от большего к меньшему, если совпадает, то -> ФИО в алфавитном порядке. Прикладываю пример. Сама таблица очень большая.

Автор - ASnin
Дата добавления - 12.05.2017 в 06:30
Nic70y Дата: Пятница, 12.05.2017, 06:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
вариант с 2-мя допами + ВПР
еще вариант (18-*) резиновый + разгруженный
К сообщению приложен файл: 7627196.xlsx(11Kb) · 18-44-27.xlsx(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 12.05.2017, 07:07
 
Ответить
Сообщениевариант с 2-мя допами + ВПР
еще вариант (18-*) резиновый + разгруженный

Автор - Nic70y
Дата добавления - 12.05.2017 в 06:50
китин Дата: Пятница, 12.05.2017, 07:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Без допов, но формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$11;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$11=$G$1;СТРОКА($B$3:$B$11)-2);СТРОКА(A1)));"")
К сообщению приложен файл: 555111.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеБез допов, но формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$11;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$11=$G$1;СТРОКА($B$3:$B$11)-2);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 12.05.2017 в 07:19
Nic70y Дата: Пятница, 12.05.2017, 07:24 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
Игорь, а вот и неправильно :p
К сообщению приложен файл: 9808529.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеИгорь, а вот и неправильно :p

Автор - Nic70y
Дата добавления - 12.05.2017 в 07:24
китин Дата: Пятница, 12.05.2017, 07:42 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и неправильно

мдя
ФИО в алфавитном порядке

не учел :'(


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
и неправильно

мдя
ФИО в алфавитном порядке

не учел :'(

Автор - китин
Дата добавления - 12.05.2017 в 07:42
and_evg Дата: Пятница, 12.05.2017, 08:10 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 34 ±
Замечаний: 0% ±

Excel 2007
А если сводными таблицами?
К сообщению приложен файл: 2036422.xlsx(13Kb)
 
Ответить
СообщениеА если сводными таблицами?

Автор - and_evg
Дата добавления - 12.05.2017 в 08:10
Nic70y Дата: Пятница, 12.05.2017, 08:17 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
Андрей, а вот и неправильно :p
К сообщению приложен файл: 5647002.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеАндрей, а вот и неправильно :p

Автор - Nic70y
Дата добавления - 12.05.2017 в 08:17
and_evg Дата: Пятница, 12.05.2017, 08:48 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 34 ±
Замечаний: 0% ±

Excel 2007
Nic70y, согласен :)
 
Ответить
СообщениеNic70y, согласен :)

Автор - and_evg
Дата добавления - 12.05.2017 в 08:48
Pelena Дата: Пятница, 12.05.2017, 09:09 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11483
Репутация: 2554 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
А если доп. столбец и сводная
К сообщению приложен файл: 5346065.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА если доп. столбец и сводная

Автор - Pelena
Дата добавления - 12.05.2017 в 09:09
ASnin Дата: Пятница, 12.05.2017, 09:44 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!!! С допами мне больше понравилось)) hands
 
Ответить
СообщениеСпасибо!!! С допами мне больше понравилось)) hands

Автор - ASnin
Дата добавления - 12.05.2017 в 09:44
_Boroda_ Дата: Пятница, 12.05.2017, 09:51 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если вот так без допов?
Кол-во
Код
=ЕСЛИОШИБКА(НАИБОЛЬШИЙ(ЕСЛИ(C$3:C$11=G$1;D$3:D$11);СТРОКА(G1));"")

ФИО
Код
=ЕСЛИ(H3="";"";ИНДЕКС(B$3:B$11;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((C$3:C$11=G$1)*(D$3:D$11=H3);СТРОКА(B$3:B$11)+СЧЁТЕСЛИ(B$3:B$11;"<="&B$3:B$11)%%);СЧЁТЕСЛИ(H$2:H3;H3));1)/1%%;0)))
К сообщению приложен файл: 410765_2.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если вот так без допов?
Кол-во
Код
=ЕСЛИОШИБКА(НАИБОЛЬШИЙ(ЕСЛИ(C$3:C$11=G$1;D$3:D$11);СТРОКА(G1));"")

ФИО
Код
=ЕСЛИ(H3="";"";ИНДЕКС(B$3:B$11;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((C$3:C$11=G$1)*(D$3:D$11=H3);СТРОКА(B$3:B$11)+СЧЁТЕСЛИ(B$3:B$11;"<="&B$3:B$11)%%);СЧЁТЕСЛИ(H$2:H3;H3));1)/1%%;0)))

Автор - _Boroda_
Дата добавления - 12.05.2017 в 09:51
sboy Дата: Пятница, 12.05.2017, 10:05 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 927
Репутация: 237 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант с одним доп.столбцом
для кол-ва
Код
=АГРЕГАТ(14;6;($C$3:$C$11=$G$1)*$D$3:$D$11;СТРОКА(G1))

для ФИО
Код
=ИНДЕКС($B$3:$B$11;АГРЕГАТ(15;6;($A$3:$A$11/(($D$3:$D$11=H3)*($C$3:$C$11=$G$1)));СЧЁТЕСЛИ($H$1:H2;H3)+1))

для доп.столбца массивная
Код
=СЧЁТ(1/(B3>$B$3:$B$11))+1
К сообщению приложен файл: 5770038.xlsx(11Kb)
 
Ответить
СообщениеДобрый день.
Вариант с одним доп.столбцом
для кол-ва
Код
=АГРЕГАТ(14;6;($C$3:$C$11=$G$1)*$D$3:$D$11;СТРОКА(G1))

для ФИО
Код
=ИНДЕКС($B$3:$B$11;АГРЕГАТ(15;6;($A$3:$A$11/(($D$3:$D$11=H3)*($C$3:$C$11=$G$1)));СЧЁТЕСЛИ($H$1:H2;H3)+1))

для доп.столбца массивная
Код
=СЧЁТ(1/(B3>$B$3:$B$11))+1

Автор - sboy
Дата добавления - 12.05.2017 в 10:05
Светлый Дата: Пятница, 12.05.2017, 12:05 | Сообщение № 13
Группа: Проверенные
Ранг: Обитатель
Сообщений: 293
Репутация: 73 ±
Замечаний: 0% ±

Excel 2007
Ещё вариант без допов с сортировкой по фамилиям, но немного переделан файл:
Код
=ИНДЕКС($B:$B;ОСТАТ(НАИБОЛЬШИЙ(($C$3:$C$99=G$1)*(9999+$D$3:$D$99&9999-СЧЁТЕСЛИ($B$3:$B$99;"<"&$B$3:$B$99)&10000+СТРОКА($D$3:$D$99));СТРОКА(G1));10000))

Файл перевложил.
К сообщению приложен файл: 4107652-3.xlsx(10Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 12.05.2017, 12:13
 
Ответить
СообщениеЕщё вариант без допов с сортировкой по фамилиям, но немного переделан файл:
Код
=ИНДЕКС($B:$B;ОСТАТ(НАИБОЛЬШИЙ(($C$3:$C$99=G$1)*(9999+$D$3:$D$99&9999-СЧЁТЕСЛИ($B$3:$B$99;"<"&$B$3:$B$99)&10000+СТРОКА($D$3:$D$99));СТРОКА(G1));10000))

Файл перевложил.

Автор - Светлый
Дата добавления - 12.05.2017 в 12:05
ASnin Дата: Пятница, 19.05.2017, 06:56 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Излишнее цитирование удалено

А как сделать, что бы не считывались пустые ячейки?


Сообщение отредактировал Pelena - Пятница, 19.05.2017, 11:36
 
Ответить
СообщениеИзлишнее цитирование удалено

А как сделать, что бы не считывались пустые ячейки?

Автор - ASnin
Дата добавления - 19.05.2017 в 06:56
Nic70y Дата: Пятница, 19.05.2017, 10:48 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
не считывались пустые ячейки?
в смысле?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
не считывались пустые ячейки?
в смысле?

Автор - Nic70y
Дата добавления - 19.05.2017 в 10:48
Pelena Дата: Пятница, 19.05.2017, 10:50 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11483
Репутация: 2554 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
ASnin, не надо цитировать пост целиком. Это нарушение Правил форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеASnin, не надо цитировать пост целиком. Это нарушение Правил форума

Автор - Pelena
Дата добавления - 19.05.2017 в 10:50
jakim Дата: Пятница, 19.05.2017, 18:38 | Сообщение № 17
Группа: Друзья
Ранг: Ветеран
Сообщений: 801
Репутация: 206 ±
Замечаний: 0% ±

Формула для количества

Код
=IFERROR(AGGREGATE(14;6;$D$3:$D$20/($C$3:$C$20=$G$1);ROWS($3:3));"")

для ФИО
Код
=IFERROR(INDEX(B$3:B$20;AGGREGATE(15;6;ROW($1:$20)/(D$3:D$20=H3)/(C$3:C$20=$G$1);COUNTIF(H$3:H3;H3)));"")

Сразу сортируем количестао, а потом по количеству выбираем ФИО.
К сообщению приложен файл: 1806397.xlsx(10Kb)
 
Ответить
Сообщение
Формула для количества

Код
=IFERROR(AGGREGATE(14;6;$D$3:$D$20/($C$3:$C$20=$G$1);ROWS($3:3));"")

для ФИО
Код
=IFERROR(INDEX(B$3:B$20;AGGREGATE(15;6;ROW($1:$20)/(D$3:D$20=H3)/(C$3:C$20=$G$1);COUNTIF(H$3:H3;H3)));"")

Сразу сортируем количестао, а потом по количеству выбираем ФИО.

Автор - jakim
Дата добавления - 19.05.2017 в 18:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая сортировка по трем критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!